aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/abiword/APKBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/community/abiword/APKBUILD b/community/abiword/APKBUILD
index 3fc688adee7..a880b613456 100644
--- a/community/abiword/APKBUILD
+++ b/community/abiword/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
-pkgver=3.0.4
-pkgrel=5
+pkgver=3.0.5
+pkgrel=0
pkgdesc="A fully-featured word processor"
-url="http://www.abisource.com"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+url="https://www.abisource.com/"
+# s390x, mips, mips64 and riscv64 blocked by librsvg
+arch="all !s390x !mips !mips64 !riscv64"
options="!check" # Test suite requires valgrind, etc
license="GPL-2.0-or-later"
makedepends="gtk+3.0-dev readline-dev libgsf-dev enchant2-dev fribidi-dev wv-dev
@@ -30,7 +30,7 @@ for _i in $_plugins; do
subpackages="$subpackages $pkgname-plugin-$_i:_plugin"
done
-source="http://www.abisource.com/downloads/abiword/$pkgver/source/abiword-$pkgver.tar.gz
+source="https://www.abisource.com/downloads/abiword/$pkgver/source/abiword-$pkgver.tar.gz
enchant.patch"
prepare() {
@@ -52,6 +52,10 @@ build() {
make
}
+check() {
+ make check
+}
+
package() {
make DESTDIR="$pkgdir" install
}
@@ -73,5 +77,7 @@ plugins() {
mkdir -p "$subpkgdir"
}
-sha512sums="121708e010cef6722cab5622dc762f2f92c46e43b65b90b881b4f25ff32c1696fa2d281a3a6f2c04d5b9231bbbd0040281e9d4d7e594ec0ace6caae9c9021ec4 abiword-3.0.4.tar.gz
-16f28eafdd1c1444dec5b3f8cbdd00f12c6178ba8db5bb94196064653cdada4cb8e4b2ac78ee9a7093c7968c0ddeb9f50a4e6209a5d5836a24b1b2f1941fb576 enchant.patch"
+sha512sums="
+a2484268901ff47307c9d1f1928622e364f1006f22ce38257c585144df9411dfe3c2dea28c1f1f50a6e545e8cc579cce34117a89dfa771e20312e3ea1a9989d6 abiword-3.0.5.tar.gz
+16f28eafdd1c1444dec5b3f8cbdd00f12c6178ba8db5bb94196064653cdada4cb8e4b2ac78ee9a7093c7968c0ddeb9f50a4e6209a5d5836a24b1b2f1941fb576 enchant.patch
+"