aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/py3-requests-oauthlib/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/community/py3-requests-oauthlib/APKBUILD b/community/py3-requests-oauthlib/APKBUILD
index d46be0c421c..78b9bf132ef 100644
--- a/community/py3-requests-oauthlib/APKBUILD
+++ b/community/py3-requests-oauthlib/APKBUILD
@@ -1,17 +1,16 @@
-# Maintainer:
+# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
pkgname=py3-requests-oauthlib
-_pkgname=requests-oauthlib
-pkgver=1.2.0
-pkgrel=1
+pkgver=1.3.0
+pkgrel=0
pkgdesc="First-class OAuth library support for Requests"
url="https://pypi.python.org/pypi/requests-oauthlib"
arch="noarch"
license="ISC"
depends="python3 py3-oauthlib py3-requests"
makedepends="py3-setuptools"
-checkdepends="py3-mock py3-requests-mock"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+checkdepends="py3-mock py3-requests-mock py3-tox"
+source="https://files.pythonhosted.org/packages/source/r/requests-oauthlib/requests-oauthlib-$pkgver.tar.gz"
+builddir="$srcdir/requests-oauthlib-$pkgver"
replaces="py-requests-oauthlib" # Backwards compatibility
provides="py-requests-oauthlib=$pkgver-r$pkgrel" # Backwards compatibility
@@ -21,11 +20,11 @@ build() {
}
check() {
- python3 setup.py test
+ tox --sitepackages
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="531cbea898b692864134b83479b3a32b0455def8bbd0b808a118bd63d377c4056e8df9a4943fa4048e5b27e2628641d8818d3bbc71dde91522a3be163da1e719 requests-oauthlib-1.2.0.tar.gz"
+sha512sums="7ef206aaf50cd3289f04175ff3a08022d00aeaaba57a6580912f37c30880322ec71ae9f6af7edc99efe6043fc6c19ba2c9f6fc0f29c126be28cde22bb885510d requests-oauthlib-1.3.0.tar.gz"