aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/git-lfs/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/community/git-lfs/APKBUILD b/community/git-lfs/APKBUILD
index f89dd47e971..080d5c5067d 100644
--- a/community/git-lfs/APKBUILD
+++ b/community/git-lfs/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=git-lfs
pkgver=2.3.4
-pkgrel=1
+pkgrel=2
pkgdesc="Git extension for versioning large files"
url="https://git-lfs.github.io/"
arch="all"
@@ -10,6 +10,8 @@ license="MIT"
depends="git"
checkdepends="bash coreutils git-daemon perl-utils"
makedepends="go ronn"
+# Go doesn't play well with strip tool. http://bit.ly/2jlJsSU
+options="!strip"
subpackages="$pkgname-doc"
install="$pkgname.post-install $pkgname.pre-deinstall"
source="$pkgname-$pkgver.tar.gz::https://github.com/git-lfs/$pkgname/archive/v$pkgver.tar.gz
@@ -70,10 +72,11 @@ package() {
}
_gobuild() {
- # netcgo - use system's DNS resolver by default. Go's built-in DNS
+ # -tags netcgo - use system's DNS resolver by default. Go's built-in DNS
# resolver is buggy; it resolved localhost to totally wrong IP
# address on ARM builders and so caused test failures.
- go build -tags netcgo -v "$@"
+ # -ldflags - omit symbol and debug tables (strip).
+ go build -tags netcgo -ldflags='-s -w' -v "$@"
}
sha512sums="97174dc9346979777c3951baa86cfc07c85e2df04f13a50114e016facbb3fd5fde08d38825493d4e7ff149a13c87ae44e9e40350cd4950f27fe309ef62b6724a git-lfs-2.3.4.tar.gz