aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/blind/APKBUILD10
-rw-r--r--community/girara/APKBUILD8
-rw-r--r--community/keyfinder-cli/APKBUILD6
-rw-r--r--community/libkeyfinder/APKBUILD8
-rw-r--r--community/libspectre/APKBUILD20
-rw-r--r--community/ocaml-lablgtk/APKBUILD8
-rw-r--r--community/py3-pyo/APKBUILD6
-rw-r--r--community/unison/APKBUILD15
-rw-r--r--community/zathura-pdf-poppler/APKBUILD6
-rw-r--r--community/zathura-ps/APKBUILD18
-rw-r--r--community/zathura/APKBUILD6
11 files changed, 46 insertions, 65 deletions
diff --git a/community/blind/APKBUILD b/community/blind/APKBUILD
index ee9ec91a9cb..399fb01fa84 100644
--- a/community/blind/APKBUILD
+++ b/community/blind/APKBUILD
@@ -1,8 +1,8 @@
-# Contributor:Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor:Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=blind
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="blind is a collection of command line video editing utilities"
url="https://tools.suckless.org/blind/"
arch="all"
@@ -13,15 +13,12 @@ source="https://dl.suckless.org/tools/blind-$pkgver.tar.gz
fix-readall.patch
test.ff.bz2
"
-builddir="$srcdir/blind-$pkgver"
build() {
- cd "$builddir"
make
}
check() {
- cd "$builddir"
# Check if blind is operational
bunzip2 < "$srcdir/test.ff.bz2" | ./blind-from-image -f > test.bl
./blind-repeat 15 test.bl | ./blind-flop | ./blind-flip \
@@ -31,7 +28,6 @@ check() {
}
package() {
- cd "$builddir"
make PREFIX="/usr" DESTDIR="$pkgdir" install
cp blind-rotate-* "$pkgdir/usr/bin/"
}
diff --git a/community/girara/APKBUILD b/community/girara/APKBUILD
index c327cc9e876..e4d0fba07b0 100644
--- a/community/girara/APKBUILD
+++ b/community/girara/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Andrew Hills <ahills@ednos.net>
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=girara
pkgver=0.3.4
-pkgrel=1
+pkgrel=2
pkgdesc="girara - gtk user interface that focuses on simplicity and minimalism"
url="https://git.pwmt.org/pwmt/girara"
arch="all"
-license="zlib"
+license="Zlib"
checkdepends="dbus"
makedepends="gtk+3.0-dev libnotify-dev json-c-dev intltool doxygen check-dev
xvfb ncurses meson ninja"
diff --git a/community/keyfinder-cli/APKBUILD b/community/keyfinder-cli/APKBUILD
index da2794835b0..60d63005aa8 100644
--- a/community/keyfinder-cli/APKBUILD
+++ b/community/keyfinder-cli/APKBUILD
@@ -1,8 +1,8 @@
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=keyfinder-cli
pkgver=1.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Musical key detection for digital audio (command line)"
url="https://github.com/EvanPurkhiser/keyfinder-cli"
arch="all"
diff --git a/community/libkeyfinder/APKBUILD b/community/libkeyfinder/APKBUILD
index dd0b81ba35e..7ef3155bc9d 100644
--- a/community/libkeyfinder/APKBUILD
+++ b/community/libkeyfinder/APKBUILD
@@ -1,8 +1,8 @@
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=libkeyfinder
pkgver=2.2.1
-pkgrel=3
+pkgrel=4
pkgdesc="Musical key detection for digital audio"
url="http://www.ibrahimshaath.co.uk/keyfinder/"
arch="all"
@@ -16,13 +16,11 @@ source="libkeyfinder-$pkgver.tar.gz::https://github.com/ibsh/libKeyFinder/archiv
builddir="$srcdir/libKeyFinder-$pkgver"
build() {
- cd "$builddir"
qmake-qt5 PREFIX=/usr
make
}
package() {
- cd "$builddir"
make INSTALL_ROOT="$pkgdir" install
install -Dm644 "$builddir"/README.md \
"$pkgdir"/usr/share/doc/$pkgname/README.md
diff --git a/community/libspectre/APKBUILD b/community/libspectre/APKBUILD
index 31508467ceb..dddde2dbf68 100644
--- a/community/libspectre/APKBUILD
+++ b/community/libspectre/APKBUILD
@@ -1,24 +1,21 @@
# Contributor: Andrew Hills <ahills@ednos.net>
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=libspectre
pkgver=0.2.8
-pkgrel=2
+pkgrel=3
pkgdesc="A small library for rendering Postscript documents"
url="http://www.freedesktop.org/wiki/Software/libspectre"
arch="all"
-license="GPL-2.0"
+license="LGPL-2.0-or-later"
makedepends="ghostscript-dev doxygen graphviz"
checkdepends="cairo-dev file"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://libspectre.freedesktop.org/releases/$pkgname-$pkgver.tar.gz
+source="https://libspectre.freedesktop.org/releases/libspectre-$pkgver.tar.gz
test.ps
"
-builddir="$srcdir/$pkgname-$pkgver"
-
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,14 +29,13 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
doc() {
- mkdir -m 0755 -p "$subpkgdir"/usr/share/doc/libspectre
- install -m 0644 "$builddir"/doc/html/* \
- "$subpkgdir"/usr/share/doc/libspectre/
+ mkdir -p "$subpkgdir/usr/share/doc/$pkgname"
+ install -m644 "$builddir"/doc/html/* \
+ "$subpkgdir/usr/share/doc/$pkgname/"
}
check() {
diff --git a/community/ocaml-lablgtk/APKBUILD b/community/ocaml-lablgtk/APKBUILD
index cd84730a921..91e3cd215d4 100644
--- a/community/ocaml-lablgtk/APKBUILD
+++ b/community/ocaml-lablgtk/APKBUILD
@@ -1,13 +1,13 @@
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=ocaml-lablgtk
_pkgname=lablgtk
pkgver=2.18.6
-pkgrel=1
+pkgrel=2
pkgdesc="An OCaml interface to GTK+ 2.x"
url="http://lablgtk.forge.ocamlcore.org/"
arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml aport
-license="LGPL-2.1-only-WITH-linking-exception"
+license="LGPL-2.1-or-later-WITH-OCaml-LGPL-linking-exception"
depends="ocaml-runtime"
depends_dev="$pkgname=$pkgver-r$pkgrel
gtk+-dev gtkspell-dev librsvg-dev gtksourceview2-dev"
diff --git a/community/py3-pyo/APKBUILD b/community/py3-pyo/APKBUILD
index 47019f17d45..9d1c92bbf2a 100644
--- a/community/py3-pyo/APKBUILD
+++ b/community/py3-pyo/APKBUILD
@@ -1,9 +1,9 @@
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=py3-pyo
_pkgname=pyo
pkgver=1.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="dedicated Python module for digital signal processing"
url="http://ajaxsoundstudio.com/software/pyo/"
arch="all"
diff --git a/community/unison/APKBUILD b/community/unison/APKBUILD
index 42cc4d334fa..7d8a1b3eabe 100644
--- a/community/unison/APKBUILD
+++ b/community/unison/APKBUILD
@@ -1,20 +1,20 @@
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=unison
# Note: unison breaks compatibility between minor (major.minor) versions.
pkgver=2.48.15_p4
_pkgver=${pkgver/_p/v}
_majorver=${_pkgver%.*} # x.y
-pkgrel=0
+pkgrel=1
pkgdesc="Efficient file-synchronization tool"
url="https://www.cis.upenn.edu/~bcpierce/unison/"
# ocaml is not built for x86, armhf, s390x
# ocaml-lablgtk is not built for aarch64
arch="all !x86 !armhf !armv7 !aarch64 !s390x"
-license="GPL-3.0+"
+license="GPL-3.0-or-later"
makedepends="ocaml ocaml-lablgtk-dev linux-headers emacs-nox bash"
subpackages="$pkgname-gui"
-source="$pkgname-$_pkgver.tar.gz::https://github.com/bcpierce00/$pkgname/archive/v$_pkgver.tar.gz
+source="unison-$_pkgver.tar.gz::https://github.com/bcpierce00/unison/archive/v$_pkgver.tar.gz
fix-inotify-check.patch
makefile-fix-clean.patch
fix-for-lablgtk-2.18.6.patch
@@ -22,11 +22,9 @@ source="$pkgname-$_pkgver.tar.gz::https://github.com/bcpierce00/$pkgname/archive
# TODO: Enable check once this issue is fixed:
# https://github.com/bcpierce00/unison/issues/73
options="!check"
-builddir="$srcdir/$pkgname-$_pkgver/src"
+builddir="$srcdir/unison-$_pkgver/src"
build() {
- cd "$builddir"
-
# ocamlopt is a front-end for gcc which will create optimized ocaml
# binaries. It will call gcc, but it hasn't implemented all gcc options.
# -ccopt is the way to pass arbitrary options.
@@ -45,7 +43,6 @@ build() {
}
package() {
- cd "$builddir"
install -m 755 -D unison-text \
"$pkgdir"/usr/bin/unison-text-$_majorver
install -m 755 -D unison-fsmonitor \
diff --git a/community/zathura-pdf-poppler/APKBUILD b/community/zathura-pdf-poppler/APKBUILD
index 83f93273e46..89701d93a74 100644
--- a/community/zathura-pdf-poppler/APKBUILD
+++ b/community/zathura-pdf-poppler/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Andrew Hills <ahills@ednos.net>
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=zathura-pdf-poppler
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Poppler plugin adds PDF support to zathura"
options="!check" # No testsuite
url="https://git.pwmt.org/pwmt/zathura-pdf-poppler"
diff --git a/community/zathura-ps/APKBUILD b/community/zathura-ps/APKBUILD
index 50580ac6d1d..75917eaf2ca 100644
--- a/community/zathura-ps/APKBUILD
+++ b/community/zathura-ps/APKBUILD
@@ -1,31 +1,25 @@
# Contributor: Andrew Hills <ahills@ednos.net>
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=zathura-ps
pkgver=0.2.6
-pkgrel=4
+pkgrel=5
pkgdesc="zathura-ps - plugin adds PostScript support to zathura"
url="https://git.pwmt.org/pwmt/zathura-ps"
arch="all"
-license="zlib"
+license="Zlib"
depends="zathura"
makedepends="zathura-dev poppler-dev libspectre-dev meson ninja"
-source="https://git.pwmt.org/pwmt/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
-
options="!check"
+source="https://git.pwmt.org/pwmt/zathura-ps/-/archive/$pkgver/zathura-ps-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
- meson build \
- --prefix=/usr \
- --buildtype=plain
+ meson build --prefix=/usr
ninja -C build
}
package() {
- cd "$builddir"
DESTDIR="$pkgdir" ninja -C build install
}
diff --git a/community/zathura/APKBUILD b/community/zathura/APKBUILD
index 2fafde29f9f..7f67f8cd5b0 100644
--- a/community/zathura/APKBUILD
+++ b/community/zathura/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Andrew Hills <ahills@ednos.net>
-# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
-# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
+# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=zathura
pkgver=0.4.5
-pkgrel=1
+pkgrel=2
pkgdesc="zathura - highly customizable and functional document viewer"
url="https://git.pwmt.org/pwmt/zathura"
arch="all"