aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/lua-copas/APKBUILD8
-rw-r--r--community/lua-copas/skip-broken-test.patch18
2 files changed, 21 insertions, 5 deletions
diff --git a/community/lua-copas/APKBUILD b/community/lua-copas/APKBUILD
index 8eac15cfe99..b8582349c9c 100644
--- a/community/lua-copas/APKBUILD
+++ b/community/lua-copas/APKBUILD
@@ -4,7 +4,7 @@ pkgname=lua-copas
_pkgname=copas
pkgver=2.0.2
_pkgver=${pkgver//./_}
-pkgrel=3
+pkgrel=4
pkgdesc="Coroutine Oriented Portable Asynchronous Services for Lua"
url="http://keplerproject.github.io/copas/"
arch="noarch"
@@ -56,8 +56,10 @@ _subpackage() {
echo 'rock_manifest = {}' > "$rockdir"/rock_manifest
}
-sha512sums="dd83a513fbddb2f0164c3573b417623f5cc556413c4937be7e362f4c1667bad83391143e1bf609480726730ce488c4080e810f2ce12a98a7abb5293993c10182 lua-copas-2.0.2.tar.gz
+sha512sums="
+dd83a513fbddb2f0164c3573b417623f5cc556413c4937be7e362f4c1667bad83391143e1bf609480726730ce488c4080e810f2ce12a98a7abb5293993c10182 lua-copas-2.0.2.tar.gz
d65a2d26ff025ec4b7c652bdf179a9f18078f736ec8f9166df077a47ec34cc4731cdeaa984d25c9556f332b36bfd9b4a7e2069284f8b63a4344e8a81b5ad72bc default-tls1.2.patch
f775cda7762f7924be8794ea2c77eb49740741a3cf9f67ca7b7e7563868d51f386ed473833e40b673af3aee5660a5e4767f43522bda1e0c38b2bf07c9df183df test-certs.patch
4fb2b65f41869b9729cc4672eebbfb2745a2d01af1cd54341b8306f57510f98e118eac77c77a980f4c8e8b181b6fda150061dc39819269e9ee64bf07656dfd54 ipv4-only.patch
-f661d6b5651496174d04bb26357ab37180b949d5c3a50d67fb090152ee3c63e37eda72754d8d6f2a84351569f74a2088ef4588e9f313583baec5057d11cc7170 skip-broken-test.patch"
+9793138edddc16ef168f07263d1a55f94d1cc973e17c51b3982c6f6cdcdc5a403993db36b65a3cecd73bd3c5d62b94b26031b6595527281370d10070e9e19585 skip-broken-test.patch
+"
diff --git a/community/lua-copas/skip-broken-test.patch b/community/lua-copas/skip-broken-test.patch
index ea48eeaf47e..63f69911a9a 100644
--- a/community/lua-copas/skip-broken-test.patch
+++ b/community/lua-copas/skip-broken-test.patch
@@ -2,7 +2,7 @@ diff --git a/tests/httpredirect.lua b/tests/httpredirect.lua
index a47b42ba0f..1f23fd9e48 100644
--- a/tests/httpredirect.lua
+++ b/tests/httpredirect.lua
-@@ -43,10 +43,11 @@ copas.addthread(function()
+@@ -43,20 +43,21 @@ copas.addthread(function()
assert(headers.location == "https://github.com/brunoos/luasec")
print("http -> https redirect OK!")
copas.addthread(function()
@@ -14,7 +14,21 @@ index a47b42ba0f..1f23fd9e48 100644
+ -- local result, code, headers, status = doreq("http://goo.gl/tBfqNu") -- http --> http redirect
+ -- assert(tonumber(code)==200)
+ -- assert(headers.location == "http://www.thijsschreijer.nl/blog/")
-+ -- print("http -> http redirect OK!")
++ print("http -> http redirect skipped!")
copas.addthread(function()
local result, code, headers, status = doreq("https://goo.gl/tBfqNu") -- https --> http security test case
assert(result==nil and code == "Unallowed insecure redirect https to http")
+ print("https -> http redirect, while not allowed OK!:", code)
+ copas.addthread(function()
+ redirect = "all"
+- local result, code, headers, status = doreq("https://goo.gl/tBfqNu") -- https --> http security test case
+- assert(tonumber(code)==200)
+- assert(headers.location == "http://www.thijsschreijer.nl/blog/")
+- print("https -> http redirect, while allowed OK!")
++ -- local result, code, headers, status = doreq("https://goo.gl/tBfqNu") -- https --> http security test case
++ -- assert(tonumber(code)==200)
++ -- assert(headers.location == "http://www.thijsschreijer.nl/blog/")
++ print("https -> http redirect, skipped while target is broken!")
+ done = true
+ end)
+ end)