aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/rustup/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/rustup/APKBUILD b/community/rustup/APKBUILD
index 72af947eacf..951e4216366 100644
--- a/community/rustup/APKBUILD
+++ b/community/rustup/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.23.1
pkgrel=0
pkgdesc="The Rust toolchain installer"
url="https://rustup.rs"
-arch="x86_64" # limited by cargo
+arch="aarch64 x86_64" # limited by cargo
license="Apache-2.0"
makedepends="cargo perl openssl-dev zlib-dev curl-dev"
options="!check" # Doesn't recognise x86_64-unknown-linux-musl yet
@@ -18,7 +18,7 @@ source="
dont-copy-rustup-bin.patch"
# It doesn't like our custom triplet
-export RUSTUP_OVERRIDE_BUILD_TRIPLE="x86_64-unknown-linux-musl"
+export RUSTUP_OVERRIDE_BUILD_TRIPLE="$CARCH-unknown-linux-musl"
build() {
cargo build --release --features no-self-update --bin rustup-init