aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/xf86-video-vesa/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/xf86-video-vesa/APKBUILD b/community/xf86-video-vesa/APKBUILD
new file mode 100644
index 00000000000..bb1e3b913ca
--- /dev/null
+++ b/community/xf86-video-vesa/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-video-vesa
+pkgver=2.5.0
+pkgrel=0
+pkgdesc="X.org generic VESA video driver"
+url="https://xorg.freedesktop.org/wiki/"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+makedepends="xorg-server-dev libxi-dev util-macros xorgproto"
+source="https://www.x.org/releases/individual/driver/xf86-video-vesa-$pkgver.tar.bz2"
+
+build() {
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+sha512sums="36fd921f54f33eb25966b5f9ea1e1b3e9009965c012c8b9c676686b472111719921b80cf62dafc746058878253e21f0ef341a2ff2d650df22ca1e35e81716a8b xf86-video-vesa-2.5.0.tar.bz2"