aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/tilix/APKBUILD17
-rw-r--r--community/tilix/ce11b0bd936fe8fee9c5ac7025ea5864b99ed7d3.patch34
-rw-r--r--community/tilix/dont-use-dub.patch17
-rw-r--r--community/tilix/dont-use-libunwind.patch32
-rw-r--r--community/tilix/fix-meson.patch11
5 files changed, 17 insertions, 94 deletions
diff --git a/community/tilix/APKBUILD b/community/tilix/APKBUILD
index 84e48231f37..9f97143905a 100644
--- a/community/tilix/APKBUILD
+++ b/community/tilix/APKBUILD
@@ -1,21 +1,19 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=tilix
-pkgver=1.9.3
-pkgrel=6
+pkgver=1.9.4
+pkgrel=0
pkgdesc="Tiling terminal emulator for Linux"
url="https://gnunn1.github.io/tilix-web/"
arch="x86_64 aarch64" # ldc
license="MPL-2.0"
depends="gsettings-desktop-schemas libsecret dbus:org.freedesktop.Secrets"
makedepends="dconf-dev gtkd-dev glib-dev libx11-dev meson ldc ldc-runtime
- ldc-static po4a gdk-pixbuf"
+ ldc-static po4a gdk-pixbuf libsecret-dev appstream desktop-file-utils"
options="!check" # no tests
+subpackages="$pkgname-doc $pkgname-lang"
source="https://github.com/gnunn1/tilix/archive/$pkgver/tilix-$pkgver.tar.gz
musl-hacks.patch
- ce11b0bd936fe8fee9c5ac7025ea5864b99ed7d3.patch
- dont-use-dub.patch
- fix-meson.patch
dont-use-libunwind.patch"
export LDFLAGS='-linker=bfd -link-defaultlib-shared'
@@ -29,9 +27,6 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="59165d24404c3fb9beb40070005131c6262abe98626c164552c0d90d0d74b3fc1d0532430b56027497674934a7fbfd2fdf4195b01915cb6d03a284f468c7adca tilix-1.9.3.tar.gz
+sha512sums="fe73cfca691317af575c37730179732b7b53a0197e9b813c918626094bff7499239c6d48d4a03204896f4f261bdb52d9ceaaf2ba3a2c100b57a0fe05abe5980f tilix-1.9.4.tar.gz
3347bfebb0e4d011d9b17f31ed15ec79e503de76185757165c7c13daa6e8b566eb0ad3a7cf32775ee4bc6102da1fa593d3dd0ff57767748c911ec46ad53d4bc3 musl-hacks.patch
-36d45c82abd9bf33e5ef9518103794b1da727204540deaa624cf7f6417541893f8391d1f8b9311a32479c58e98d3e85ca292aa2c009179cc8f69e41f23d8ed00 ce11b0bd936fe8fee9c5ac7025ea5864b99ed7d3.patch
-2d4d3ca80249abe49af5823d3541de00afdc41a3b37cb9b897a1cdef7c4c2c41d03812e85132fbc56e83d43b15e463dbae260e7cfca164ae5ec5d04f36a50573 dont-use-dub.patch
-8b2356d3c708e5b02185e4c140faffe51a1963478d51f7e91261246f9c37958a4c168f57883322c3567169279174cdff06d4b9999aade3c61f083f8ed5f34a24 fix-meson.patch
-425868cd83b5b29a49bc9a2936f9b5be802318cf09c122e9a6809be4844a8a6864441799393eabbac4d2294496a811f3b672f8ca32576709babdb387fd1e15f7 dont-use-libunwind.patch"
+4a1ccc6011d64b78a7f2a93ca91eec36004c5e5d4e826efc115f860c3013bd52477324b586340e18849bce445c56d7d8b909393694ec43a3b11d0c85e6ad59c3 dont-use-libunwind.patch"
diff --git a/community/tilix/ce11b0bd936fe8fee9c5ac7025ea5864b99ed7d3.patch b/community/tilix/ce11b0bd936fe8fee9c5ac7025ea5864b99ed7d3.patch
deleted file mode 100644
index b0952df26f5..00000000000
--- a/community/tilix/ce11b0bd936fe8fee9c5ac7025ea5864b99ed7d3.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From ce11b0bd936fe8fee9c5ac7025ea5864b99ed7d3 Mon Sep 17 00:00:00 2001
-From: LuK1337 <priv.luk@gmail.com>
-Date: Mon, 15 Jul 2019 20:42:21 +0200
-Subject: [PATCH] Avoid calling `values()` on a shared object
-
-* This fixes a compilation on dmd v2.087.0+ ( I think? )
- /usr/include/dmd/druntime/import/object.d(3453,36): Error: cannot implicitly convert expression aa of type shared(ProcessStatus[int]) to const(shared(ProcessStatus)[int])
- source/gx/tilix/terminal/monitor.d(46,46): Error: template instance `object.values!(shared(ProcessStatus[int]), shared(ProcessStatus), int)` error instantiating
----
- source/gx/tilix/terminal/monitor.d | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/source/gx/tilix/terminal/monitor.d b/source/gx/tilix/terminal/monitor.d
-index 2b130efe..affc4b86 100644
---- a/source/gx/tilix/terminal/monitor.d
-+++ b/source/gx/tilix/terminal/monitor.d
-@@ -43,7 +43,7 @@ private:
-
- bool fireEvents() {
- synchronized {
-- foreach(process; processes.values()) {
-+ foreach(process; processes) {
- if (process.eventType != MonitorEventType.NONE) {
- onChildProcess.emit(process.eventType, process.gpid, process.activePid, process.activeName);
- process.eventType = MonitorEventType.NONE;
-@@ -138,7 +138,7 @@ void monitorProcesses(int sleep, Tid tid) {
- // all open terminals. We need to get these using shell
- // PID and will store them to raise events for each terminal.
- auto activeProcesses = getActiveProcessList();
-- foreach(process; processes.values()) {
-+ foreach(process; processes) {
- auto activeProcess = activeProcesses.get(process.gpid, null);
- // No need to raise event for same process.
- if (activeProcess !is null && activeProcess.pid != process.activePid) {
diff --git a/community/tilix/dont-use-dub.patch b/community/tilix/dont-use-dub.patch
deleted file mode 100644
index 38a425863b9..00000000000
--- a/community/tilix/dont-use-dub.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -93,12 +93,8 @@ source_root = meson.source_root()
- sources_dir = include_directories('source/')
-
- # Dependencies
--# Note relying on dub to fetch and build dependencies before running meson build is temporary due to a bug in Meson 0.48
--# gtkd_dep = dependency('gtkd-3', version: '>= 3.8.5')
--# vted_dep = dependency('vted-3', version: '>= 3.8.5')
--
--gtkd_dep = dependency('gtk-d:gtkd', version: '>=3.8.5', method: 'dub')
--vted_dep = dependency('gtk-d:vte', version: '>=3.8.5', method: 'dub')
-+gtkd_dep = dependency('gtkd-3', version: '>= 3.8.5')
-+vted_dep = dependency('vted-3', version: '>= 3.8.5')
- xlib_dep = dependency('x11')
- libunwind_dep = dependency('libunwind')
- msgfmt = find_program('msgfmt')
diff --git a/community/tilix/dont-use-libunwind.patch b/community/tilix/dont-use-libunwind.patch
index 7e68967c2fd..8c179052d5b 100644
--- a/community/tilix/dont-use-libunwind.patch
+++ b/community/tilix/dont-use-libunwind.patch
@@ -1,30 +1,20 @@
-We already link with llvm-libunwind via ldc
diff --git a/meson.build b/meson.build
-index ab6a7dd..80522ea 100644
+index 448e262..a717fca 100644
--- a/meson.build
+++ b/meson.build
-@@ -96,7 +96,6 @@ sources_dir = include_directories('source/')
- gtkd_dep = dependency('gtkd-3', version: '>= 3.8.5')
- vted_dep = dependency('vted-3', version: '>= 3.8.5')
+@@ -100,7 +100,6 @@ sources_dir = include_directories('source/')
+ gtkd_dep = dependency('gtkd-3', version: '>=3.8.5')
+ vted_dep = dependency('vted-3', version: '>=3.8.5')
xlib_dep = dependency('x11')
-libunwind_dep = dependency('libunwind')
- msgfmt = find_program('msgfmt')
+ libsecret_dep = dependency('libsecret-1', required: false)
subdir('po')
-@@ -108,8 +107,7 @@ executable('tilix',
- include_directories : sources_dir,
+@@ -113,7 +112,6 @@ executable('tilix',
dependencies : [gtkd_dep,
vted_dep,
-- xlib_dep,
-- libunwind_dep],
-+ xlib_dep],
- d_args: extra_args,
- link_args: d_link_args,
- install : true
-@@ -126,4 +124,4 @@ executable('tilix',
- #)
- #test('tilix_test', tilix_test_exe)
-
--meson.add_install_script('meson_post_install.py')
-\ No newline at end of file
-+meson.add_install_script('meson_post_install.py')
+ xlib_dep,
+- libunwind_dep,
+ libsecret_dep],
+ d_args: d_extra_args,
+ d_module_versions: ['StdLoggerDisableTrace'],
diff --git a/community/tilix/fix-meson.patch b/community/tilix/fix-meson.patch
deleted file mode 100644
index a48992192a0..00000000000
--- a/community/tilix/fix-meson.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/data/meson.build
-+++ b/data/meson.build
-@@ -98,7 +98,7 @@ conf.set('bindir', join_paths(get_option('prefix'), get_option('bindir')))
-
- configure_file(
- input: 'dbus/@0@.service.in'.format(meson.project_name()),
-- output: 'dbus/@0@.service'.format(meson.project_name()),
-+ output: '@0@.service'.format(meson.project_name()),
- configuration: conf,
- install_dir: join_paths(get_option('datadir'), 'dbus-1/services')
- )