aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/runvimtests/APKBUILD31
-rw-r--r--community/runvimtests/runvimtests.post-install2
2 files changed, 33 insertions, 0 deletions
diff --git a/community/runvimtests/APKBUILD b/community/runvimtests/APKBUILD
new file mode 100644
index 00000000000..af951f2c02b
--- /dev/null
+++ b/community/runvimtests/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=runvimtests
+_pkgname=runVimTests
+pkgver=1.30
+pkgrel=0
+pkgdesc="A testing framework for Vim"
+url="https://github.com/inkarkat/runVimTests"
+arch="noarch"
+license="Vim"
+depends="vim bash"
+options="!check" # no return codes from test suite
+install="$pkgname.post-install"
+source="$pkgname-$pkgver.tar.gz::https://github.com/inkarkat/runVimTests/archive/$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+package() {
+ local _dest="$pkgdir/usr/share/vim/vimfiles"
+
+ install -t "$_dest/bin" -D bin/runVimMsgFilter.vim
+ install -t "$_dest/bin" -D bin/runVimTests.sh
+
+ cp -R doc autoload "$_dest"
+
+ mkdir -p "$pkgdir/usr/bin"
+ cd "$pkgdir/usr/bin"
+ ln -s ../share/vim/vimfiles/bin/runVimTests.sh runVimTests
+}
+
+sha512sums="d016d0e1fec531d168ceb9c2bd6df34ab31592c5349867ea979ebf45111e86d21893a3edafc326bb246019b5f94733dbaa87a289b49c09d6e60da3fdde42b383 runvimtests-1.30.tar.gz"
diff --git a/community/runvimtests/runvimtests.post-install b/community/runvimtests/runvimtests.post-install
new file mode 100644
index 00000000000..0bc5bd9954d
--- /dev/null
+++ b/community/runvimtests/runvimtests.post-install
@@ -0,0 +1,2 @@
+#!/bin/sh
+vim -u NONE -esX "+helptags ALL" +q