aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/ceph/30-cypress.patch.noauto2
-rw-r--r--community/ceph/44-missing-include2.patch90
-rw-r--r--community/ceph/APKBUILD10
3 files changed, 96 insertions, 6 deletions
diff --git a/community/ceph/30-cypress.patch.noauto b/community/ceph/30-cypress.patch.noauto
index 8e747532706..fecf0559155 100644
--- a/community/ceph/30-cypress.patch.noauto
+++ b/community/ceph/30-cypress.patch.noauto
@@ -4,9 +4,9 @@ diff -Nurp a/src/pybind/mgr/dashboard/frontend/package.json b/src/pybind/mgr/das
--- a/src/pybind/mgr/dashboard/frontend/package.json 2021-04-03 08:58:07.611941559 +0100
+++ b/src/pybind/mgr/dashboard/frontend/package.json 2021-04-03 08:59:13.903122038 +0100
@@ -119,8 +119,6 @@
+ "@types/node": "12.12.62",
"@types/simplebar": "5.1.1",
"codelyzer": "6.0.1",
- "css-loader": "3.6.0",
- "cypress": "5.3.0",
- "cypress-multi-reporters": "1.4.0",
"html-linter": "1.1.1",
diff --git a/community/ceph/44-missing-include2.patch b/community/ceph/44-missing-include2.patch
index 6e19c58b357..6974cd86ff0 100644
--- a/community/ceph/44-missing-include2.patch
+++ b/community/ceph/44-missing-include2.patch
@@ -25,3 +25,93 @@ index b599e48b34..362deffb5a 100644
#include <set>
#include <limits>
+From 7c2f58ea5ec70e5606ab362e6f4cfda087cec65a Mon Sep 17 00:00:00 2001
+From: Kefu Chai <kchai@redhat.com>
+Date: Mon, 12 Apr 2021 17:32:59 +0800
+Subject: [PATCH] mon,osd: always init local variable
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+this change silences the warning like:
+
+../src/mon/Monitor.cc: In member function ‘void Monitor::handle_command(MonOpRequestRef)’:
+../src/mon/Monitor.cc:3703:55: warning: ‘osd’ may be used uninitialized in this function [-Wmaybe-uninitialized]
+ 3703 | uint64_t seq = mgrstatmon()->get_last_osd_stat_seq(osd);
+ | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~
+
+Signed-off-by: Kefu Chai <kchai@redhat.com>
+---
+ src/mon/Monitor.cc | 2 +-
+ src/osd/osd_types.h | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/mon/Monitor.cc b/src/mon/Monitor.cc
+index 6126db9caa609..ffac8be278c16 100644
+--- a/src/mon/Monitor.cc
++++ b/src/mon/Monitor.cc
+@@ -3698,7 +3698,7 @@ void Monitor::handle_command(MonOpRequestRef op)
+ rs = ss2.str();
+ r = 0;
+ } else if (prefix == "osd last-stat-seq") {
+- int64_t osd;
++ int64_t osd = 0;
+ cmd_getval(cmdmap, "id", osd);
+ uint64_t seq = mgrstatmon()->get_last_osd_stat_seq(osd);
+ if (f) {
+diff --git a/src/osd/osd_types.h b/src/osd/osd_types.h
+index c0fe8f781c21e..fe2fe7defa9a8 100644
+--- a/src/osd/osd_types.h
++++ b/src/osd/osd_types.h
+@@ -1631,12 +1631,12 @@ struct pg_pool_t {
+ }
+
+ int64_t get_dedup_tier() const {
+- int64_t tier_id;
++ int64_t tier_id = 0;
+ opts.get(pool_opts_t::DEDUP_TIER, &tier_id);
+ return tier_id;
+ }
+ int64_t get_dedup_cdc_chunk_size() const {
+- int64_t chunk_size;
++ int64_t chunk_size = 0;
+ opts.get(pool_opts_t::DEDUP_CDC_CHUNK_SIZE, &chunk_size);
+ return chunk_size;
+ }
+From 03770f75562812c683ff1503d2032dcd66d83289 Mon Sep 17 00:00:00 2001
+From: Kefu Chai <kchai@redhat.com>
+Date: Mon, 12 Apr 2021 17:43:13 +0800
+Subject: [PATCH] include/denc: include used header
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+to address the FTBFS like:
+
+/home/kchai/ceph/src/include/denc.h: In member function ‘void DencDumper<T>::dump() const’:
+/home/kchai/ceph/src/include/denc.h:121:60: error: ‘O_BINARY’ was not declared in this scope
+ int fd = ::open(fn, O_WRONLY|O_TRUNC|O_CREAT|O_CLOEXEC|O_BINARY, 0644);
+ ^~~~~~~~
+/home/kchai/ceph/src/include/denc.h:121:60: note: the macro ‘O_BINARY’ had not yet been defined
+In file included from /home/kchai/ceph/src/include/statlite.h:14,
+ from /home/kchai/ceph/src/include/types.h:41,
+ from /home/kchai/ceph/src/auth/Crypto.h:19,
+ from /home/kchai/ceph/src/auth/Crypto.cc:21:
+
+Signed-off-by: Kefu Chai <kchai@redhat.com>
+---
+ src/include/denc.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/include/denc.h b/src/include/denc.h
+index 266121bd20cda..10fa8d0c87124 100644
+--- a/src/include/denc.h
++++ b/src/include/denc.h
+@@ -39,6 +39,7 @@
+ #include <boost/intrusive/set.hpp>
+ #include <boost/optional.hpp>
+
++#include "include/compat.h"
+ #include "include/intarith.h"
+ #include "include/int_types.h"
+ #include "include/scope_guard.h"
diff --git a/community/ceph/APKBUILD b/community/ceph/APKBUILD
index 7e51b745a84..09500a9cea6 100644
--- a/community/ceph/APKBUILD
+++ b/community/ceph/APKBUILD
@@ -3,8 +3,8 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=ceph
-pkgver=16.2.4
-pkgrel=2
+pkgver=16.2.5
+pkgrel=0
pkgdesc="Ceph is a distributed object store and file system"
pkgusers="ceph"
pkggroups="ceph"
@@ -535,13 +535,13 @@ mgr() {
}
sha512sums="
-8904e7fcabd50276e4e86735fd85dba96f417c194c219025146f994707def7abe372528b0f2e862e274b2f405d7b791bac86b6cbb8d57cecd6f44023a2ffb6f6 ceph_16.2.4.orig.tar.gz
+5c32f9aa817ecfa788725bcfe5743756853ca9b3f9ee453242110f1b5e1bdd1feaef79ad9ccf2b185445c9644bcecb1355e151a2255bfd27edc9818e0d6d4c4a ceph_16.2.5.orig.tar.gz
110bdbcb40216c7ed155a8d23020784741b4992d895f4f04a146d275506e4e68053854d3b063b41e9c9b3e3e4f95b6b90602f92c185c853c0d8f47ad0c6b7121 ceph.confd
ce5f162501f6b67fe254546dddf880d1a5b1d1a0fa69e0b1918de17e8da45c5c6124512b8cbd98b76f29d931403de0d11c5ffd330ed8ee1f4dc75bb04baecae3 ceph.initd
94687578411bf0de1b17555ed81c188c88ea63ac4a25993bd8fde9cf68afbbfbdec7b2d7c54fdcfbd4aed4eb78754e8061c308955596cbe037ff15b575874cc6 10-musl-fixes.patch
03ef3598181c45ecba5600a1e4db7fd897ea9d3c8abdfaad2dcf84c7a241d9ba18e7f7885d69ee0572ee307fc94600a2784a07da909d37a51de27f8ded2e3a70 20-pci.patch
b879993a285a771c3640c5214ff70e8e01673c0c5e23a0f88ac70db168aeb1dd2eaed12805ed5076adae5a0f596abcb9d82220c6fd97643169cb92788898a189 30-32bit_fix.patch.noauto
-013ff1e35fd91b4b4a9d712701e78975f423a883650b391d9fe73dbc2ab68f02ecd1fa51e1ba6bc60c483b021f99c0d4b9e80a8e19492bd2f31ffed159a356a7 30-cypress.patch.noauto
+2eebc4501d40edf92c5302b25dea554807caba6abd22a3569d708db8a057085d74a3ecdac2adab54edb0619cf3d74884e1d44ef95d991a069dd473279819b974 30-cypress.patch.noauto
01c446ac4528d8e12d3544f603ba32a0bf0d5a3a72f9f8f3726725f9d225ee447d2fea4ee2ddf10b36498cc01f2ecf51175dbfcc6376aac4c8002f52c6a04299 30-ubuntu-32bit-fixes.patch.noauto
f974ab36cd6fa49c1d4613203a4f2152723e4952a185dfb6349bc4ca8ee1a7a9d0477bea136c54248271de30a4e584734ba41e8ec41bf274b04074622888ae39 31-32bit_fix_tests.patch.noauto
964e7ca107cc731be2be7bf6813aca760ca1c6e6f6b3748103c1e6baef4d25e41442752a72f5e5daed2b1c6c4f96c9aebbb7114247e8a5047511fbd035767aeb 32-PurgeQueue.cc-cast.patch
@@ -556,5 +556,5 @@ e47d736d3ab1417758fc5f92798a77272b978799e6d9f0728b2036d6cc5975c6c10f8dc4590c2e1c
f89c913a53e2806c59508d26f5dc72abb428c7e4e3b7c1aeb6eaf92744ea9a13cac2f00a2ac90f91ad7682f66d876a5fffedd10feeceecd71a944793581da443 44-staticcast.patch
85d0009b0d1442af81d115402cdbd17667d85314030e1748a4656c1ee798b02efdcff41ccb374a6b63f7bf012bf1756b61e75c5d2b6399c329a6e62024ad0011 44-node_modules.patch
b95ec157f9c77177afd3deb8e3485bb5f10e1b634a15617d14e09b08d6680d32201ecb249ea5ea98127a312e1fdb22fdbe9f0216690291a2849419aa7ab81610 44-missing-include.patch
-a8faf754e5778f8df7e52603b1948d25e90a34994c2176ab247789cd55dd5722970babfbe50c41b52526b3e1f3373e4677c5b70ab37abf55f24be9a34fcf222d 44-missing-include2.patch
+8269647901e2c10d2e85668abb34f44a0b394460fb89e4eeb6dbf3eb964764a9e4b56b1ec90ab07da428ae33ad3147ea51830fdd83654e1b8b4c179db90b5e1f 44-missing-include2.patch
"