aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/xf86-video-siliconmotion/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/xf86-video-siliconmotion/APKBUILD b/community/xf86-video-siliconmotion/APKBUILD
new file mode 100644
index 00000000000..f3504429a08
--- /dev/null
+++ b/community/xf86-video-siliconmotion/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-video-siliconmotion
+pkgver=1.7.9
+pkgrel=3
+pkgdesc="Silicon Motion video driver"
+url="https://xorg.freedesktop.org"
+arch="x86_64 x86"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=
+makedepends="xorg-server-dev libxi-dev util-macros xorgproto"
+source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2
+ "
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+sha512sums="13085945ca496f83521c28b25c394077e010031dbdc2374347a932a52650ada02f525269a81d0b0bb20b48e371d5435a7a73cb7555a07dc5a784e77152608c63 xf86-video-siliconmotion-1.7.9.tar.bz2"