aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/py3-pytest-runner/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-pytest-runner/APKBUILD b/community/py3-pytest-runner/APKBUILD
new file mode 100644
index 00000000000..18545d7f9e2
--- /dev/null
+++ b/community/py3-pytest-runner/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pytest-runner
+_pkgname=pytest-runner
+pkgver=4.4
+pkgrel=0
+pkgdesc="Invoke py.test as distutils command"
+options="!check" # Requires unpackaged pytest-{checkdocs,flake8,virtualenv}
+url="https://github.com/pytest-dev/pytest-runner"
+arch="noarch"
+license="MIT"
+depends="py3-setuptools"
+makedepends="py3-setuptools_scm"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3122e556bc7ad41f48a8044b6c8555aed41bbed1ccaafe39bbd0aff51c4b656c4de954ccd99b5122f95763dad7ad54a2ae78d4e9522364ea6bbafecb967b09f5 pytest-runner-4.4.tar.gz"