aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/telegram-desktop/APKBUILD21
-rw-r--r--community/telegram-desktop/qt-plugin-path.patch3
2 files changed, 6 insertions, 18 deletions
diff --git a/community/telegram-desktop/APKBUILD b/community/telegram-desktop/APKBUILD
index 6e82caf7871..31938ff2d34 100644
--- a/community/telegram-desktop/APKBUILD
+++ b/community/telegram-desktop/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
pkgname=telegram-desktop
pkgver=2.1.6
-pkgrel=0
+pkgrel=1
pkgdesc="Telegram Desktop messaging app"
options="!check" # Requires Catch2 to be packaged.
url="https://desktop.telegram.org/"
@@ -73,24 +73,9 @@ build() {
}
package() {
- install -d "$pkgdir"/usr/bin \
- "$pkgdir"/usr/share/applications \
- "$pkgdir"/usr/share/appdata \
- "$pkgdir"/usr/share/kservices5 \
-
- install -m755 build/bin/telegram-desktop -t "$pkgdir"/usr/bin
- install -m644 lib/xdg/telegramdesktop.desktop "$pkgdir"/usr/share/applications/org.telegram.desktop.desktop
- install -m644 build/Telegram/telegramdesktop.appdata.xml "$pkgdir"/usr/share/appdata/org.telegram.desktop.appdata.xml
-
- for icon_size in 16 32 48 64 128 256 512; do
- icon_dir="$pkgdir/usr/share/icons/hicolor/${icon_size}x$icon_size/apps"
-
- install -d "$icon_dir"
- install -m644 "$builddir/Telegram/Resources/art/icon$icon_size.png" \
- "$icon_dir/telegram.png"
- done
+ DESTDIR="$pkgdir" ninja -C build install
}
sha512sums="a6a105676d8d24ec3414895cadc664829c5abc041d8614409e22d7964d7280e44df35ece5fca18a0cd127f65bd363abc1e5c36807b0031eabd6eb77c7effdfb8 tdesktop-2.1.6-full.tar.gz
-183767e9a291dd605797cdc46382d8cb6a73a342348a40df7d52864ea27b3aa8709808cd51c46f5e611c247229ed336cb569bed1185c4c97b03171b56bbe5653 qt-plugin-path.patch
+6126ba461cb4b3f5bfb864cac3270fe1b4cd8c2e88781e756959bdcf00830c4af3354d2d056411f1b69198f2b5eae968bee6908ab720bb90fbb6ac656e4e77c4 qt-plugin-path.patch
3d1b8e6f870fc780f9ae8bc6a67eb676a5c5f686dc79e84cd6d64cb3cfafb1be626d0cc3960ffc67cecca21568764a0137c7303a89045fa59f91ba4eb5d8caed small-sizes.patch"
diff --git a/community/telegram-desktop/qt-plugin-path.patch b/community/telegram-desktop/qt-plugin-path.patch
index bb877f901d4..905de3ec27c 100644
--- a/community/telegram-desktop/qt-plugin-path.patch
+++ b/community/telegram-desktop/qt-plugin-path.patch
@@ -1,3 +1,6 @@
+Upstream: No (not applicable)
+Reason: Fix loading plugins and startup
+
diff --git a/Telegram/SourceFiles/core/launcher.cpp b/Telegram/SourceFiles/core/launcher.cpp
index 2547342..8a14dcb 100644
--- a/Telegram/SourceFiles/core/launcher.cpp