aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/libqmi/APKBUILD12
-rw-r--r--community/libqmi/musl-compat-canonicalize_file_name.patch27
2 files changed, 4 insertions, 35 deletions
diff --git a/community/libqmi/APKBUILD b/community/libqmi/APKBUILD
index 309c018957a..8cb1e96fac2 100644
--- a/community/libqmi/APKBUILD
+++ b/community/libqmi/APKBUILD
@@ -1,18 +1,15 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=libqmi
-pkgver=1.18.0
-pkgrel=2
+pkgver=1.20.0
+pkgrel=0
pkgdesc="QMI modem protocol helper library"
url="http://www.freedesktop.org/wiki/Software/libqmi"
arch="all"
license="GPL-2.0"
makedepends="gtk-doc python2 glib-dev libgudev-dev linux-headers"
-options="!check" #FIXME
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz
- musl-compat-canonicalize_file_name.patch
- "
+source="https://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -37,5 +34,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="3890501fa2299ce5ac8fda732363e39738c95ffb153708d8f727e88c082014018463c569a0d9666385f6394d060ec41052dec400f3f6c733e78748ca7ee56b76 libqmi-1.18.0.tar.xz
-f7a660cc391d0821b681790b57a8b450dff2b0540af816cfa0b674100d97a79399307050e41f6302f2755c90e5dee448ff82806e00e6b42b50f984cfea263ac8 musl-compat-canonicalize_file_name.patch"
+sha512sums="fceec9aff22942fa64f7a568527033354dc379f347b96c9b37844bbdfb7bfa0936f554402b855c4b191fd63ca488776b94ee69e84502a460e941caddbd648b63 libqmi-1.20.0.tar.xz"
diff --git a/community/libqmi/musl-compat-canonicalize_file_name.patch b/community/libqmi/musl-compat-canonicalize_file_name.patch
deleted file mode 100644
index 15b38493746..00000000000
--- a/community/libqmi/musl-compat-canonicalize_file_name.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- libqmi-1.17.901/src/libqmi-glib/qmi-utils.h
-+++ libqmi-1.17.901/src/libqmi-glib/qmi-utils.h.new
-@@ -29,6 +29,24 @@
- #error "Only <libqmi-glib.h> can be included directly."
- #endif
-
-+#ifndef HAVE_CANONICALIZE_FILE_NAME
-+#include <limits.h>
-+#include <string.h>
-+#include <stdlib.h>
-+#include <stdio.h>
-+static char * canonicalize_file_name(const char *path)
-+{
-+ char buf[PATH_MAX] = { };
-+
-+ snprintf(buf, sizeof(buf) - 1, "%s", path);
-+
-+ if (!realpath(path, buf))
-+ return NULL;
-+
-+ return strdup(buf);
-+}
-+#endif
-+
- #include <glib.h>
-
- G_BEGIN_DECLS