aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/telegram-desktop/APKBUILD9
-rw-r--r--community/telegram-desktop/qt-plugin-path.patch27
2 files changed, 3 insertions, 33 deletions
diff --git a/community/telegram-desktop/APKBUILD b/community/telegram-desktop/APKBUILD
index ac2835e376c..62af792e77a 100644
--- a/community/telegram-desktop/APKBUILD
+++ b/community/telegram-desktop/APKBUILD
@@ -2,13 +2,13 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
pkgname=telegram-desktop
pkgver=2.1.11
-pkgrel=0
+pkgrel=1
pkgdesc="Telegram Desktop messaging app"
options="!check" # Requires Catch2 to be packaged.
url="https://desktop.telegram.org/"
arch="all !s390x !mips !mips64" # Need support on lib_base
license="GPL-3.0-or-later WITH OpenSSL"
-depends="qt5-qtimageformats libappindicator"
+depends="qt5-qtimageformats ttf-opensans"
makedepends="
cmake
samurai
@@ -31,7 +31,6 @@ makedepends="
qtchooser
pulseaudio-dev
libdbusmenu-glib-dev
- libappindicator-dev
xxhash-dev
enchant2-dev
range-v3-dev
@@ -42,7 +41,6 @@ makedepends="
"
source="
https://github.com/telegramdesktop/tdesktop/releases/download/v$pkgver/tdesktop-$pkgver-full.tar.gz
- qt-plugin-path.patch
small-sizes.patch
remove-glibc.patch
"
@@ -66,9 +64,9 @@ build() {
-DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF \
-DTDESKTOP_USE_PACKAGED_TGVOIP=OFF \
-DTDESKTOP_LAUNCHER_BASENAME=telegram-desktop \
- -DTDESKTOP_FORCE_GTK_FILE_DIALOG=ON \
-DDESKTOP_APP_USE_PACKAGED_GSL=OFF \
-DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF \
+ -DDESKTOP_APP_USE_PACKAGED_FONTS=ON \
$CMAKE_CROSSOPTS .
ninja -C build
}
@@ -78,6 +76,5 @@ package() {
}
sha512sums="9f2fba2814a5ab64f946913e32fce66dbc842d9607cbaee00994689ef6a661a04c2a8de5e075fc532e7d8926b51432c06c2b1510b019d729eef40da373d91d42 tdesktop-2.1.11-full.tar.gz
-6126ba461cb4b3f5bfb864cac3270fe1b4cd8c2e88781e756959bdcf00830c4af3354d2d056411f1b69198f2b5eae968bee6908ab720bb90fbb6ac656e4e77c4 qt-plugin-path.patch
3d1b8e6f870fc780f9ae8bc6a67eb676a5c5f686dc79e84cd6d64cb3cfafb1be626d0cc3960ffc67cecca21568764a0137c7303a89045fa59f91ba4eb5d8caed small-sizes.patch
453e9d474a38609f928fc4fbe021d044ce0f80c5a4cb67ff914fbf159c8b9eb22116e75d8b4d518be95892a87f77360b9f310bff1ade05cd4abef42df07366b6 remove-glibc.patch"
diff --git a/community/telegram-desktop/qt-plugin-path.patch b/community/telegram-desktop/qt-plugin-path.patch
deleted file mode 100644
index 905de3ec27c..00000000000
--- a/community/telegram-desktop/qt-plugin-path.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Upstream: No (not applicable)
-Reason: Fix loading plugins and startup
-
-diff --git a/Telegram/SourceFiles/core/launcher.cpp b/Telegram/SourceFiles/core/launcher.cpp
-index 2547342..8a14dcb 100644
---- a/Telegram/SourceFiles/core/launcher.cpp
-+++ b/Telegram/SourceFiles/core/launcher.cpp
-@@ -278,6 +278,19 @@ int Launcher::exec() {
- Platform::start();
- Ui::DisableCustomScaling();
-
-+ // I don't know why path is not in QT_PLUGIN_PATH by default
-+ QCoreApplication::addLibraryPath("/usr/lib/qt5/plugins");
-+ // without this Telegram doesn't start on Ubuntu 17.04 due GTK errors
-+ setenv("QT_STYLE_OVERRIDE", "qwerty", false);
-+ // Telegram doesn't start when extraordinary theme is set, see launchpad.net/bugs/1680943
-+ unsetenv("QT_QPA_PLATFORMTHEME");
-+
-+ // unset QT screen scale related envvars
-+ unsetenv("QT_SCREEN_SCALE_FACTORS");
-+ unsetenv("QT_AUTO_SCREEN_SCALE_FACTOR");
-+ unsetenv("QT_SCALE_FACTOR");
-+ unsetenv("QT_DEVICE_PIXEL_RATIO");
-+
- auto result = executeApplication();
-
- DEBUG_LOG(("Telegram finished, result: %1").arg(result));