aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/py3-requests-cache/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/py3-requests-cache/APKBUILD b/community/py3-requests-cache/APKBUILD
new file mode 100644
index 00000000000..345b0280ed6
--- /dev/null
+++ b/community/py3-requests-cache/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Philipp Glaum <p@pglaum.de>
+# Maintainer: Philipp Glaum <p@pglaum.de>
+pkgname=py3-requests-cache
+_pkgname=requests-cache
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="Persistent cache for requests library"
+url="https://pypi.org/project/requests-cache/"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-requests"
+makedepends="py3-setuptools"
+checkdepends="py3-mock"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="net" # Required for tests
+builddir="$srcdir/$_pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ # Invoke python3
+ sed -i "s|os.system('python %s' % test)|os.system('python3 %s' % test)|" setup.py
+}
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="355cc571a46b768615606a907a69ed065b3c4b5e74bb6c311abc7a28d9406f32fdea1db0dfd2b1c32dcdc82ed817ef7e0b30086c069de57307254617604c5177 requests-cache-0.5.2.tar.gz"