aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/emacs/APKBUILD28
1 files changed, 22 insertions, 6 deletions
diff --git a/community/emacs/APKBUILD b/community/emacs/APKBUILD
index dfe9d277ce2..0498dea434a 100644
--- a/community/emacs/APKBUILD
+++ b/community/emacs/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
pkgname=emacs
pkgver=27.1
-pkgrel=1
+pkgrel=2
pkgdesc="The extensible, customizable, self-documenting real-time display editor"
# s390x, mips, mips64: librsvg
arch="all !s390x !mips !mips64"
@@ -10,11 +10,11 @@ depends="emacs-nox"
url="https://www.gnu.org/software/emacs/emacs.html"
license="GPL-3.0-or-later"
makedepends="autoconf automake linux-headers paxmark gawk
- librsvg-dev giflib-dev libxpm-dev gtk+2.0-dev alsa-lib-dev
+ librsvg-dev giflib-dev libxpm-dev gtk+2.0-dev gtk+3.0-dev alsa-lib-dev
glib-dev fontconfig-dev libpng-dev
libxml2-dev pango-dev tiff-dev libjpeg-turbo-dev ncurses-dev
ncurses-libs gnutls-dev libxaw-dev gmp-dev harfbuzz-dev jansson-dev"
-subpackages="$pkgname-doc $pkgname-nox $pkgname-x11 $pkgname-gtk2"
+subpackages="$pkgname-doc $pkgname-nox $pkgname-x11 $pkgname-gtk2 $pkgname-gtk3"
source="https://ftp.gnu.org/gnu/emacs/emacs-$pkgver.tar.xz
no-git-repo.patch"
@@ -63,6 +63,14 @@ _build_gtk2() {
--with-tiff=no
}
+_build_gtk3() {
+ _build_variant gtk3 \
+ --with-x-toolkit=gtk3 \
+ --with-xft \
+ --with-jpeg=yes \
+ --with-tiff=no
+}
+
_build_nox() {
_build_variant nox \
--without-sound \
@@ -74,10 +82,12 @@ build() {
mkdir -p nox
mv * nox || true
cp -a nox gtk2
+ cp -a nox gtk3
cp -a nox x11
_build_x11
_build_nox
_build_gtk2
+ _build_gtk3
}
package() {
@@ -123,21 +133,27 @@ _subpackage() {
nox() {
pkgdesc="$pkgdesc - without X11"
- depends="!emacs-x11 !emacs-gtk2"
+ depends="!emacs-x11 !emacs-gtk2 !emacs-gtk3"
_subpackage nox
}
x11() {
pkgdesc="$pkgdesc - with X11"
- depends="!emacs-nox !emacs-gtk2 hicolor-icon-theme desktop-file-utils"
+ depends="!emacs-nox !emacs-gtk2 !emacs-gtk3 hicolor-icon-theme desktop-file-utils"
_subpackage x11
}
gtk2() {
pkgdesc="$pkgdesc - with GTK2"
- depends="!emacs-nox !emacs-x11 hicolor-icon-theme desktop-file-utils"
+ depends="!emacs-nox !emacs-x11 !emacs-gtk3 hicolor-icon-theme desktop-file-utils"
_subpackage gtk2
}
+gtk3() {
+ pkgdesc="$pkgdesc - with GTK3"
+ depends="!emacs-nox !emacs-x11 !emacs-gtk2 hicolor-icon-theme desktop-file-utils"
+ _subpackage gtk3
+}
+
sha512sums="dfb26531d2c19cf9fb56505f03d799654b45e5f9528e777900e8280ed2c1d21e04c52f510528e31e015977c471ae63164cedee6174b7439ebcf479a21fc18064 emacs-27.1.tar.xz
5a2d1d10d66fd335b16d9f2d6d1e45e093067db87f8ef2d14a8c921cc94b3e226310c7cc691d19eb91eaf16de9ae4f20ff8be3596a4906b0514fa5f098328d97 no-git-repo.patch"