aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/glfw/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/glfw/APKBUILD b/community/glfw/APKBUILD
new file mode 100644
index 00000000000..117168a3145
--- /dev/null
+++ b/community/glfw/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
+pkgname=glfw
+pkgver=3.3.2
+pkgrel=1
+pkgdesc="Multi-platform library for OpenGL and Vulkan application development"
+url="https://www.glfw.org/"
+arch="all"
+license="Zlib"
+depends_dev="libxinerama-dev linux-headers mesa-dev"
+makedepends="$depends_dev cmake libx11-dev libxcursor-dev libxrandr-dev
+ libxi-dev"
+subpackages="$pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/glfw/glfw/archive/$pkgver.tar.gz"
+
+
+build() {
+ cmake . \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=ON
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir/" install
+}
+
+sha512sums="f5af749d33b5b900ccf07988ad0bf51bd766a18e4cf2bc2a76020c88e98a2528ff1b965224184fe0d290cfe34b1af1e6f633600660d81194fe354078e2f35c56 glfw-3.3.2.tar.gz"