aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/connman/APKBUILD19
-rw-r--r--community/connman/libresolv.patch12
-rw-r--r--community/connman/musl-fixes.patch166
3 files changed, 16 insertions, 181 deletions
diff --git a/community/connman/APKBUILD b/community/connman/APKBUILD
index 83a0c83bfc3..870f9051cec 100644
--- a/community/connman/APKBUILD
+++ b/community/connman/APKBUILD
@@ -1,10 +1,10 @@
# Maintainer: Clayton Craft <clayton@craftyguy.net>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=connman
-pkgver=1.36
-pkgrel=1
+pkgver=1.37
+pkgrel=0
pkgdesc="A daemon for managing internet connections"
-url="https://connman.net"
+url="https://01.org/connman"
arch="all"
license="GPL-2.0-only"
depends="wpa_supplicant"
@@ -12,12 +12,11 @@ makedepends="autoconf automake dbus-dev glib-dev iptables-dev libtool
readline-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-openrc"
source="https://www.kernel.org/pub/linux/network/connman/$pkgname-$pkgver.tar.xz
- musl-fixes.patch
libresolv.patch
connman.initd
"
-
builddir="$srcdir"/$pkgname-$pkgver
+
prepare() {
default_prepare
cd "$builddir"
@@ -38,6 +37,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
@@ -45,7 +49,6 @@ package() {
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-sha512sums="c0b9e924a28d58539d44c314168ae7aa46dfea8ce9d125198f525a6d6ef95ca77fd0357c4c4c7548b362b9de8e6f85c7915b1a4cf89b65116c4cbc4df75318e1 connman-1.36.tar.xz
-2ed156edca3f2e7f02256f601df288a484dcabb968750a0d26cac3de56079859d1ff7fd73853c1797eb4c71a26072713c9668ed61e407c75bafbed561d3a9126 musl-fixes.patch
-c258e747e13b86c81ae96ac1743abf0c1461b9053c5b386d594a49f0b1890f10d89bea92610762ff609a4cc5fea04a43fab83894702f552b05af400f01cb011e libresolv.patch
+sha512sums="5d5363105aedd0c9d609dd5c64eb832d9ff80923a944d9d3738337a61f180ded227f2ae1ff7912bed8826b35f0cfd20488e3ffd3801f0e53e90f98498e19efb6 connman-1.37.tar.xz
+122b48fc9e25354e25ba3a3e0864bdd84da84457fed94aeea726bcb189b2f05f2cc361ae15f44af5c49bcee572e91e4c0488ef3b0bc79d20f6efe15853fb6b3a libresolv.patch
42b45d44f5eed966ba003683fcb54ffb4e9a0331599ff1c8e5e64c4c06b42d380c3852b7c73881a1be1eaca887906cac9aede1f5579e8e139fdf90ca8d7adf15 connman.initd"
diff --git a/community/connman/libresolv.patch b/community/connman/libresolv.patch
index c28a7c1e358..3786b86cefb 100644
--- a/community/connman/libresolv.patch
+++ b/community/connman/libresolv.patch
@@ -1,9 +1,8 @@
musl does not implement res_ninit
-diff --exclude '*.*o' -ru connman-1.24.orig/gweb/gresolv.c connman-1.24/gweb/gresolv.c
---- connman-1.24.orig/gweb/gresolv.c 2014-07-18 20:17:25.000000000 -0300
-+++ connman-1.24/gweb/gresolv.c 2014-07-18 20:24:01.874669130 -0300
-@@ -874,8 +874,6 @@
+--- a/gweb/gresolv.c
++++ b/gweb/gresolv.c
+@@ -877,8 +877,6 @@
resolv->index = index;
resolv->nameserver_list = NULL;
@@ -12,7 +11,7 @@ diff --exclude '*.*o' -ru connman-1.24.orig/gweb/gresolv.c connman-1.24/gweb/gre
return resolv;
}
-@@ -915,8 +913,6 @@
+@@ -918,8 +916,6 @@
flush_nameservers(resolv);
@@ -21,7 +20,7 @@ diff --exclude '*.*o' -ru connman-1.24.orig/gweb/gresolv.c connman-1.24/gweb/gre
g_free(resolv);
}
-@@ -1019,24 +1015,19 @@
+@@ -1022,24 +1018,19 @@
debug(resolv, "hostname %s", hostname);
if (!resolv->nameserver_list) {
@@ -58,4 +57,3 @@ diff --exclude '*.*o' -ru connman-1.24.orig/gweb/gresolv.c connman-1.24/gweb/gre
}
if (!resolv->nameserver_list)
-
diff --git a/community/connman/musl-fixes.patch b/community/connman/musl-fixes.patch
deleted file mode 100644
index e3b646e3705..00000000000
--- a/community/connman/musl-fixes.patch
+++ /dev/null
@@ -1,166 +0,0 @@
---- ./configure.ac.orig
-+++ ./configure.ac
-@@ -171,6 +171,8 @@
- AM_CONDITIONAL(PPTP, test "${enable_pptp}" != "no")
- AM_CONDITIONAL(PPTP_BUILTIN, test "${enable_pptp}" = "builtin")
-
-+AC_CHECK_MEMBERS([struct in6_pktinfo.ipi6_addr], [], [], [[#include <netinet/in.h>]])
-+AC_CHECK_HEADERS(execinfo.h)
- AC_CHECK_HEADERS(resolv.h, dummy=yes,
- AC_MSG_ERROR(resolver header files are required))
- AC_CHECK_LIB(resolv, ns_initparse, dummy=yes, [
-diff --git a/gdhcp/common.c b/gdhcp/common.c
-index e111150..ee4dc43 100644
---- a/gdhcp/common.c
-+++ b/gdhcp/common.c
-@@ -22,6 +22,7 @@
- #include <config.h>
- #endif
-
-+#define _GNU_SOURCE
- #include <stdio.h>
- #include <stdlib.h>
- #include <errno.h>
-@@ -31,7 +32,6 @@
- #include <string.h>
- #include <endian.h>
- #include <net/if_arp.h>
--#include <linux/if.h>
- #include <netpacket/packet.h>
- #include <net/ethernet.h>
- #include <arpa/inet.h>
-@@ -39,6 +39,8 @@
- #include "gdhcp.h"
- #include "common.h"
-
-+#include <linux/if.h>
-+
- static const DHCPOption client_options[] = {
- { OPTION_IP, 0x01 }, /* subnet-mask */
- { OPTION_IP | OPTION_LIST, 0x03 }, /* routers */
-diff --git a/src/log.c b/src/log.c
-index a693bd0..9054462 100644
---- a/src/log.c
-+++ b/src/log.c
- static void signal_handler(int signo)
-diff --git a/tools/dhcp-test.c b/tools/dhcp-test.c
-index c34e10a..eae66fc 100644
---- a/tools/dhcp-test.c
-+++ b/tools/dhcp-test.c
-@@ -33,7 +33,6 @@
- #include <arpa/inet.h>
- #include <net/route.h>
- #include <net/ethernet.h>
--#include <linux/if_arp.h>
-
- #include <gdhcp/gdhcp.h>
-
-diff --exclude '*.*o' -ru connman-1.24.orig/plugins/wifi.c connman-1.24/plugins/wifi.c
---- connman-1.24.orig/plugins/wifi.c 2014-06-07 21:46:22.000000000 -0300
-+++ connman-1.24/plugins/wifi.c 2014-07-18 20:37:16.811343663 -0300
-@@ -30,9 +30,8 @@
- #include <string.h>
- #include <sys/ioctl.h>
- #include <sys/socket.h>
--#include <linux/if_arp.h>
--#include <linux/wireless.h>
- #include <net/ethernet.h>
-+#include <linux/wireless.h>
-
- #ifndef IFF_LOWER_UP
- #define IFF_LOWER_UP 0x10000
-
-diff --exclude '*.*o' -ru connman-1.24.orig/tools/dnsproxy-test.c connman-1.24/tools/dnsproxy-test.c
---- connman-1.24.orig/tools/dnsproxy-test.c 2013-12-05 09:12:12.000000000 -0200
-+++ connman-1.24/tools/dnsproxy-test.c 2014-07-18 20:36:37.484676606 -0300
-@@ -24,6 +24,7 @@
- #endif
-
- #include <errno.h>
-+#include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
- #include <unistd.h>
-diff --exclude '*.*o' -ru connman-1.24.orig/tools/private-network-test.c connman-1.24/tools/private-network-test.c
---- connman-1.24.orig/tools/private-network-test.c 2013-08-19 19:57:25.000000000 -0300
-+++ connman-1.24/tools/private-network-test.c 2014-07-18 20:28:42.644671909 -0300
-@@ -32,7 +32,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <signal.h>
--#include <sys/poll.h>
-+#include <poll.h>
- #include <sys/signalfd.h>
- #include <unistd.h>
-
-diff --exclude '*.*o' -ru connman-1.24.orig/tools/tap-test.c connman-1.24/tools/tap-test.c
---- connman-1.24.orig/tools/tap-test.c 2013-12-05 09:12:12.000000000 -0200
-+++ connman-1.24/tools/tap-test.c 2014-07-18 20:28:35.351338499 -0300
-@@ -29,7 +29,7 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <string.h>
--#include <sys/poll.h>
-+#include <poll.h>
- #include <sys/ioctl.h>
-
- #include <netinet/in.h>
-diff '--exclude=*.*o' -ru connman-1.24.orig/gweb/gresolv.c connman-1.24/gweb/gresolv.c
---- connman-1.24.orig/gweb/gresolv.c 2014-07-18 20:43:40.000000000 -0300
-+++ connman-1.24/gweb/gresolv.c 2014-07-18 20:44:43.284681413 -0300
-@@ -24,6 +24,7 @@
- #endif
-
- #include <errno.h>
-+#include <stdio.h>
- #include <unistd.h>
- #include <stdarg.h>
- #include <string.h>
-diff '--exclude=*.*o' -ru connman-1.24.orig/src/ippool.c connman-1.24/src/ippool.c
---- connman-1.24.orig/src/ippool.c 2014-04-04 15:12:07.000000000 -0300
-+++ connman-1.24/src/ippool.c 2014-07-18 20:44:56.068014872 -0300
-@@ -28,7 +28,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <unistd.h>
--#include <sys/errno.h>
-+#include <errno.h>
- #include <sys/socket.h>
-
- #include "connman.h"
-diff '--exclude=*.*o' -ru connman-1.24.orig/src/iptables.c connman-1.24/src/iptables.c
---- connman-1.24.orig/src/iptables.c 2014-04-04 15:12:07.000000000 -0300
-+++ connman-1.24/src/iptables.c 2014-07-18 20:44:25.844681240 -0300
-@@ -28,7 +28,7 @@
- #include <stdio.h>
- #include <string.h>
- #include <unistd.h>
--#include <sys/errno.h>
-+#include <errno.h>
- #include <sys/socket.h>
- #include <xtables.h>
-
-
---- ./gdhcp/common.h.orig
-+++ ./gdhcp/common.h
-@@ -18,6 +18,9 @@
- * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
- *
- */
-+#ifdef HAVE_CONFIG_H
-+#include <config.h>
-+#endif
-
- #include <netinet/udp.h>
- #include <netinet/ip.h>
-@@ -170,8 +173,8 @@
- [OPTION_U32] = 4,
- };
-
--/* already defined within netinet/in.h if using GNU compiler */
--#ifndef __USE_GNU
-+/* already defined within netinet/in.h if using GNU or musl libc */
-+#ifndef HAVE_STRUCT_IN6_PKTINFO_IPI6_ADDR
- struct in6_pktinfo {
- struct in6_addr ipi6_addr; /* src/dst IPv6 address */
- unsigned int ipi6_ifindex; /* send/recv interface index */