aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rwxr-xr-xcommunity/php7-pecl-yaml/10-detect.patch11
-rw-r--r--community/php7-pecl-yaml/APKBUILD11
2 files changed, 4 insertions, 18 deletions
diff --git a/community/php7-pecl-yaml/10-detect.patch b/community/php7-pecl-yaml/10-detect.patch
deleted file mode 100755
index ee0f01746eb..00000000000
--- a/community/php7-pecl-yaml/10-detect.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/detect.c 2017-07-29 17:56:18.000000000 -0400
-+++ b/detect.c 2017-10-30 21:15:09.000000000 -0400
-@@ -568,7 +568,7 @@ finish:
- break;
-
- default:
-- *dval = atof(buf);
-+ *dval = zend_strtod(buf, (const char **) NULL);
- break;
- }
- }
diff --git a/community/php7-pecl-yaml/APKBUILD b/community/php7-pecl-yaml/APKBUILD
index 47591d71335..bd45878ee49 100644
--- a/community/php7-pecl-yaml/APKBUILD
+++ b/community/php7-pecl-yaml/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Renoir Boulanger <hello@renoirboulanger.com>
pkgname=php7-pecl-yaml
_pkgreal=yaml
-pkgver=2.0.2
-pkgrel=2
+pkgver=2.0.3
+pkgrel=0
pkgdesc="YAML syntax bindings for PHP"
url="https://pecl.php.net/package/yaml"
arch="all"
@@ -10,8 +10,7 @@ license="MIT"
makedepends="php7-dev autoconf yaml-dev"
depends="php7-common"
# Set source file explicitly, otherwise extracted archive directory breaks the build.
-source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz
- 10-detect.patch"
+source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir/$_pkgreal-$pkgver"
provides="php7-yaml=$pkgver-r$pkgrel" # for backward compatibility
replaces="php7-yaml" # for backward compatibility
@@ -26,7 +25,6 @@ build() {
}
# Thanks to @TBK for https://github.com/php/pecl-file_formats-yaml/pull/29
-# added here as 10-detect.patch
check() {
cd "$builddir"
make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
@@ -39,5 +37,4 @@ package() {
echo "extension=$_pkgreal.so" > $pkgdir/etc/php7/conf.d/70_$_pkgreal.ini
}
-sha512sums="b3dd2098826cd7cdcfd1e5d97b9015de66812dc90e506e74a4a50a56afed5f9de0449465bb807a36a13170f479897cc62a9b108653aa7eb81895abd5966bde1a php7-pecl-yaml-2.0.2.tgz
-3c291ef43ecf43c79d8e02821a6168362404b130f75e154c710fea167c10c71e0f4ffa5be8ca41c0533362d0d3a4d6a140d226f76b84e187788302adba942b4e 10-detect.patch"
+sha512sums="8ed5302b18098afe6a789c2b56d2356ae5b7dd58b9ffe8b2cc574868bc99642ac650e21041d68e6c5a43981df1ab2939f64bf28e9c8482e08e145437cc874316 php7-pecl-yaml-2.0.3.tgz"