aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
Diffstat (limited to 'community')
-rw-r--r--community/bubblejail/APKBUILD30
-rw-r--r--community/bubblejail/fish_completions.patch12
-rw-r--r--community/bubblejail/ld_cache.patch14
3 files changed, 56 insertions, 0 deletions
diff --git a/community/bubblejail/APKBUILD b/community/bubblejail/APKBUILD
new file mode 100644
index 00000000000..5f60fd7a5ee
--- /dev/null
+++ b/community/bubblejail/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Donoban <donoban@riseup.net>
+pkgname=bubblejail
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="Bubblewrap based sandboxing for desktop applications"
+url="https://github.com/igo95862/bubblejail"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="python3 bubblewrap py3-xdg py3-toml"
+makedepends="meson m4 py3-sphinx fish"
+subpackages="$pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-fish-completion"
+source="bubblejail-$pkgver.tar.gz::https://github.com/igo95862/bubblejail/archive/refs/tags/$pkgver.tar.gz
+ fish_completions.patch
+ ld_cache.patch"
+options="!check" # No tests
+
+build() {
+ abuild-meson . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
+}
+
+package() {
+ DESTDIR=$pkgdir meson install --no-rebuild -C output
+}
+
+sha512sums="c619a90830d7af0d64863369107708c782c3cc43d8afa16785d4fb62c00b532962039a47338214c57045f810f130f9cd5c4a9677c0f53a0565aae4fddbeb0422 bubblejail-0.4.2.tar.gz
+75cac90d0c4689bb29714aa4cd8ad507f4c8a813927c34d9c1aede3d5316bca219225848f45bca3ce9e5d103df7c9fa6059dd932fdd946297a15ccd9616aef38 fish_completions.patch
+5a78e5da4e06b43bd4e0198d1924eeed792b45ba1db12ec1d957afc99ed8653c793a0a5d978a2910194a26974bf04d595bb60df6eba52ccc76c7103aa8aa7cd2 ld_cache.patch"
diff --git a/community/bubblejail/fish_completions.patch b/community/bubblejail/fish_completions.patch
new file mode 100644
index 00000000000..ad979d2fa3c
--- /dev/null
+++ b/community/bubblejail/fish_completions.patch
@@ -0,0 +1,12 @@
+diff --git a/data/meson.build b/data/meson.build
+index 5ddeb09..5234a48 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -27,6 +27,6 @@ install_data(
+
+ install_data(
+ 'bubblejail_completion.fish',
+- install_dir : get_option('datadir') / 'fish/vendor_completions.d',
++ install_dir : get_option('datadir') / 'fish/completions',
+ rename : 'bubblejail.fish',
+ )
diff --git a/community/bubblejail/ld_cache.patch b/community/bubblejail/ld_cache.patch
new file mode 100644
index 00000000000..709c12f1d53
--- /dev/null
+++ b/community/bubblejail/ld_cache.patch
@@ -0,0 +1,14 @@
+diff --git a/bubblejail/services.py b/bubblejail/services.py
+index abf9bf7..fd2533f 100644
+--- a/bubblejail/services.py
++++ b/bubblejail/services.py
+@@ -346,9 +346,6 @@ class BubblejailDefaults(BubblejailService):
+ yield ReadOnlyBind('/etc/login.defs') # ???: is this file needed
+ # ldconfig: linker cache
+ # particularly needed for steam runtime to work
+- yield ReadOnlyBind('/etc/ld.so.cache')
+- yield ReadOnlyBind('/etc/ld.so.conf')
+- yield ReadOnlyBind('/etc/ld.so.conf.d')
+
+ # Temporary directories
+ yield DirCreate('/tmp')