summaryrefslogtreecommitdiffstats
path: root/core/busybox/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'core/busybox/APKBUILD')
-rw-r--r--core/busybox/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/core/busybox/APKBUILD b/core/busybox/APKBUILD
index 123cf954eff..62e1fb769ea 100644
--- a/core/busybox/APKBUILD
+++ b/core/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.13.3
-pkgrel=2
+pkgrel=3
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license=GPL-2
@@ -34,6 +34,8 @@ build() {
make || return 1
make install DESTDIR="$pkgdir"
mkdir -p "$pkgdir"/usr/sbin "$pkgdir"/usr/bin
+ # we need /bin/sh to be able to execute post-install
+ ln -s /bin/busybox "$pkgdir"/bin/sh
}
md5sums="0cde6d2790e790837d6d7e82faae3ca1 busybox-1.13.3.tar.bz2
@@ -43,6 +45,6 @@ a743ec04f378b8456a725c7270b0be8b busybox-1.13.2-modprobe-errormsg.patch
3c43008545e069749d2d653532e1feb3 busybox-1.13.2-depmod2.patch
ed7537bc7193ab35f4e4ac6ce26d8270 busybox-1.13.3-ash.patch
4a5fe634708150f65b6d9b51dba20a51 busybox-1.13.3-hush.patch
-542ea5a470af0db6794ba38db9f8e779 busybox.post-install
-542ea5a470af0db6794ba38db9f8e779 busybox.post-upgrade
+56b78c358797cd15fb64719a48939267 busybox.post-install
+56b78c358797cd15fb64719a48939267 busybox.post-upgrade
fa6b9e2021102a53c43875ef0704d6f3 busyboxconfig"