summaryrefslogtreecommitdiffstats
path: root/main/abuild/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/abuild/APKBUILD')
-rw-r--r--main/abuild/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
new file mode 100644
index 00000000000..4122b36fd27
--- /dev/null
+++ b/main/abuild/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgdesc="Script to build Alpine Packages"
+pkgname=abuild
+pkgver=1.16
+pkgrel=1
+url=http://git.alpinelinux.org/cgit/abuild/
+source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
+ 0001-core-abuild-fix-options-order-to-apk-add.patch
+ "
+depends="fakeroot file sudo pax-utils"
+license=GPL-2
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -p1 < ../0001-core-abuild-fix-options-order-to-apk-add.patch \
+ || return 1
+
+ make install DESTDIR="$pkgdir"
+ install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
+}
+
+md5sums="d6aa9ae0b28491c687f6575a6b219780 abuild-1.16.tar.bz2
+13ea88d46143b30d5c4fe261d6e80228 0001-core-abuild-fix-options-order-to-apk-add.patch"