aboutsummaryrefslogtreecommitdiffstats
path: root/main/alsa-lib
diff options
context:
space:
mode:
Diffstat (limited to 'main/alsa-lib')
-rw-r--r--main/alsa-lib/APKBUILD20
-rw-r--r--main/alsa-lib/alsa-lib-poll.patch155
-rw-r--r--main/alsa-lib/alsa-lib-stdint.patch (renamed from main/alsa-lib/alsa-lib_mixed_types.patch)59
-rw-r--r--main/alsa-lib/alsa-lib_pcm_h.patch25
4 files changed, 209 insertions, 50 deletions
diff --git a/main/alsa-lib/APKBUILD b/main/alsa-lib/APKBUILD
index da4188c63eb..00779397000 100644
--- a/main/alsa-lib/APKBUILD
+++ b/main/alsa-lib/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alsa-lib
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="An alternative implementation of Linux sound support"
url="http://www.alsa-project.org"
arch="all"
@@ -9,9 +9,9 @@ license="LGPL2+"
depends=""
subpackages="$pkgname-dev $pkgname-dbg"
makedepends="linux-headers"
-source="http://alsa.cybermirror.org/lib/$pkgname-$pkgver.tar.bz2
- alsa-lib_pcm_h.patch
- alsa-lib_mixed_types.patch
+source="ftp://ftp.alsa-project.org/pub/lib/$pkgname-$pkgver.tar.bz2
+ alsa-lib-poll.patch
+ alsa-lib-stdint.patch
"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -51,11 +51,11 @@ package() {
}
md5sums="69515ca73c3c4a212ef45160dea846c1 alsa-lib-1.1.0.tar.bz2
-4018a2f02d7c93935b6a8fa0bc3f2191 alsa-lib_pcm_h.patch
-d949fb5ff425e70f1896f7231f30469e alsa-lib_mixed_types.patch"
+59f635281241399e8783b077ce022dfc alsa-lib-poll.patch
+1349b595ef97c42873b917b2cf7c0e37 alsa-lib-stdint.patch"
sha256sums="dfde65d11e82b68f82e562ab6228c1fb7c78854345d3c57e2c68a9dd3dae1f15 alsa-lib-1.1.0.tar.bz2
-faa8efc9b2e5d110d0daffe473c86efcbc6305a7eafd016b1334581db466dbdf alsa-lib_pcm_h.patch
-ac2b77959404ea81d2f1a539c9c0e9e15b5c2c452285712aa10b6f8da8f9eefa alsa-lib_mixed_types.patch"
+6e3b26b5cc26ce81d196d22b020dc9870d8f7ff02ef05f62d62d43497e7d91f8 alsa-lib-poll.patch
+5cd15e2bbccf72d04a20db9f11bdd4dee3342f5c365d8141450916e263d9aebc alsa-lib-stdint.patch"
sha512sums="2939d0b621c1c619b0a492b05f2e84f354d588c9cc982d93dbcf01c582319258dd5f803ff5c10be52343cd8827d690f671ab5b20ad586a0ee371f0949c9e98f4 alsa-lib-1.1.0.tar.bz2
-0ea37cda27b440c82f0bc0e34f67d423678d348874c18063036e4347f961bbbce4074ed0aaa518d25d0cedd73818e66e1cbc30c6ff4bf9e6479f64012df0199c alsa-lib_pcm_h.patch
-990d83a761958f350749fda57def15c73890afeae4fa303dc6af36c453a723a2c98d3cf8f44344da539e6c3224d96bfa91861e59126ec2a3d97dc4c0f36fbc61 alsa-lib_mixed_types.patch"
+19168fd85cac28baba42d0da9cb89ceefc7b15532c4fe0c2ff6e87294334dd364f87430f47ad612bd63240cdbb3b08165e48cfd7aa45489b5ad7286cd80e0f21 alsa-lib-poll.patch
+2351262dade9a3c1a3de1b7d1a3a53a634a438b9b8aae7cc69e2b981500051f039e6381359b81392114ec6236e3d513b577bd4bf12c3d2ce1f871cd7651b2cab alsa-lib-stdint.patch"
diff --git a/main/alsa-lib/alsa-lib-poll.patch b/main/alsa-lib/alsa-lib-poll.patch
new file mode 100644
index 00000000000..f3d2d88d38e
--- /dev/null
+++ b/main/alsa-lib/alsa-lib-poll.patch
@@ -0,0 +1,155 @@
+diff -ru alsa-lib-1.1.0.orig/aserver/aserver.c alsa-lib-1.1.0/aserver/aserver.c
+--- alsa-lib-1.1.0.orig/aserver/aserver.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/aserver/aserver.c 2016-02-11 14:31:58.800479098 +0200
+@@ -20,7 +20,7 @@
+
+ #include <sys/shm.h>
+ #include <sys/socket.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/un.h>
+ #include <sys/uio.h>
+ #include <stdio.h>
+diff -ru alsa-lib-1.1.0.orig/include/asoundlib-head.h alsa-lib-1.1.0/include/asoundlib-head.h
+--- alsa-lib-1.1.0.orig/include/asoundlib-head.h 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/include/asoundlib-head.h 2016-02-11 14:31:58.800479098 +0200
+@@ -35,6 +35,6 @@
+ #include <string.h>
+ #include <fcntl.h>
+ #include <assert.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <errno.h>
+ #include <stdarg.h>
+diff -ru alsa-lib-1.1.0.orig/include/asoundlib.h alsa-lib-1.1.0/include/asoundlib.h
+--- alsa-lib-1.1.0.orig/include/asoundlib.h 2015-11-09 09:40:19.000000000 +0200
++++ alsa-lib-1.1.0/include/asoundlib.h 2016-02-11 14:31:58.800479098 +0200
+@@ -35,7 +35,7 @@
+ #include <string.h>
+ #include <fcntl.h>
+ #include <assert.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <errno.h>
+ #include <stdarg.h>
+ #include <endian.h>
+diff -ru alsa-lib-1.1.0.orig/include/local.h alsa-lib-1.1.0/include/local.h
+--- alsa-lib-1.1.0.orig/include/local.h 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/include/local.h 2016-02-11 14:31:58.797145726 +0200
+@@ -47,7 +47,7 @@
+ #error Header defining endianness not defined
+ #endif
+ #include <stdarg.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/types.h>
+ #include <errno.h>
+ #include <linux/types.h>
+diff -ru alsa-lib-1.1.0.orig/src/control/control.c alsa-lib-1.1.0/src/control/control.c
+--- alsa-lib-1.1.0.orig/src/control/control.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/src/control/control.c 2016-02-11 14:31:58.807145843 +0200
+@@ -48,7 +48,7 @@
+ #include <string.h>
+ #include <fcntl.h>
+ #include <signal.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include "control_local.h"
+
+ /**
+diff -ru alsa-lib-1.1.0.orig/src/control/control_shm.c alsa-lib-1.1.0/src/control/control_shm.c
+--- alsa-lib-1.1.0.orig/src/control/control_shm.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/src/control/control_shm.c 2016-02-11 14:31:58.800479098 +0200
+@@ -27,7 +27,7 @@
+ #include <fcntl.h>
+ #include <sys/shm.h>
+ #include <sys/socket.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/un.h>
+ #include <sys/uio.h>
+ #include <sys/mman.h>
+diff -ru alsa-lib-1.1.0.orig/src/pcm/pcm.c alsa-lib-1.1.0/src/pcm/pcm.c
+--- alsa-lib-1.1.0.orig/src/pcm/pcm.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/src/pcm/pcm.c 2016-02-11 14:31:58.833812820 +0200
+@@ -634,7 +634,7 @@
+ #include <stdarg.h>
+ #include <signal.h>
+ #include <ctype.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/mman.h>
+ #include <limits.h>
+ #include "pcm_local.h"
+diff -ru alsa-lib-1.1.0.orig/src/pcm/pcm_direct.c alsa-lib-1.1.0/src/pcm/pcm_direct.c
+--- alsa-lib-1.1.0.orig/src/pcm/pcm_direct.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/src/pcm/pcm_direct.c 2016-02-11 14:31:58.837146193 +0200
+@@ -30,7 +30,7 @@
+ #include <grp.h>
+ #include <sys/ioctl.h>
+ #include <sys/mman.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/shm.h>
+ #include <sys/sem.h>
+ #include <sys/wait.h>
+diff -ru alsa-lib-1.1.0.orig/src/pcm/pcm_mmap.c alsa-lib-1.1.0/src/pcm/pcm_mmap.c
+--- alsa-lib-1.1.0.orig/src/pcm/pcm_mmap.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/src/pcm/pcm_mmap.c 2016-02-11 14:31:58.817145959 +0200
+@@ -22,7 +22,7 @@
+ #include <stdio.h>
+ #include <malloc.h>
+ #include <string.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/mman.h>
+ #ifdef HAVE_SYS_SHM_H
+ #include <sys/shm.h>
+diff -ru alsa-lib-1.1.0.orig/src/pcm/pcm_share.c alsa-lib-1.1.0/src/pcm/pcm_share.c
+--- alsa-lib-1.1.0.orig/src/pcm/pcm_share.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/src/pcm/pcm_share.c 2016-02-11 14:31:58.820479332 +0200
+@@ -34,7 +34,7 @@
+ #include <signal.h>
+ #include <math.h>
+ #include <sys/socket.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <pthread.h>
+ #include "pcm_local.h"
+
+diff -ru alsa-lib-1.1.0.orig/src/pcm/pcm_shm.c alsa-lib-1.1.0/src/pcm/pcm_shm.c
+--- alsa-lib-1.1.0.orig/src/pcm/pcm_shm.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/src/pcm/pcm_shm.c 2016-02-11 14:31:58.820479332 +0200
+@@ -36,7 +36,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/shm.h>
+ #include <sys/socket.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/un.h>
+ #include <sys/mman.h>
+ #include <netinet/in.h>
+diff -ru alsa-lib-1.1.0.orig/src/seq/seq.c alsa-lib-1.1.0/src/seq/seq.c
+--- alsa-lib-1.1.0.orig/src/seq/seq.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/src/seq/seq.c 2016-02-11 14:31:58.813812587 +0200
+@@ -777,7 +777,7 @@
+
+ */
+
+-#include <sys/poll.h>
++#include <poll.h>
+ #include "seq_local.h"
+
+ /****************************************************************************
+diff -ru alsa-lib-1.1.0.orig/src/shmarea.c alsa-lib-1.1.0/src/shmarea.c
+--- alsa-lib-1.1.0.orig/src/shmarea.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/src/shmarea.c 2016-02-11 14:31:58.807145843 +0200
+@@ -27,7 +27,7 @@
+ #include <malloc.h>
+ #include <string.h>
+ #include <errno.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include <sys/mman.h>
+ #include <sys/shm.h>
+ #include "list.h"
diff --git a/main/alsa-lib/alsa-lib_mixed_types.patch b/main/alsa-lib/alsa-lib-stdint.patch
index 98697539151..16d4cbeb645 100644
--- a/main/alsa-lib/alsa-lib_mixed_types.patch
+++ b/main/alsa-lib/alsa-lib-stdint.patch
@@ -1,6 +1,34 @@
---- alsa-lib-1.0.25.orig/src/pcm/pcm_misc.c 2013-07-22 23:16:24.942000003 +0000
-+++ alsa-lib-1.0.25/src/pcm/pcm_misc.c 2013-07-22 23:18:34.345000003 +0000
-@@ -363,7 +363,7 @@
+diff -ru alsa-lib-1.1.0.orig/include/pcm.h alsa-lib-1.1.0/include/pcm.h
+--- alsa-lib-1.1.0.orig/include/pcm.h 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/include/pcm.h 2016-02-11 14:28:23.731309152 +0200
+@@ -33,6 +33,7 @@
+ extern "C" {
+ #endif
+
++#include <stdint.h>
+ /**
+ * \defgroup PCM PCM Interface
+ * See the \ref pcm page for more details.
+@@ -1108,10 +1109,10 @@
+ int snd_pcm_format_physical_width(snd_pcm_format_t format); /* in bits */
+ snd_pcm_format_t snd_pcm_build_linear_format(int width, int pwidth, int unsignd, int big_endian);
+ ssize_t snd_pcm_format_size(snd_pcm_format_t format, size_t samples);
+-u_int8_t snd_pcm_format_silence(snd_pcm_format_t format);
+-u_int16_t snd_pcm_format_silence_16(snd_pcm_format_t format);
+-u_int32_t snd_pcm_format_silence_32(snd_pcm_format_t format);
+-u_int64_t snd_pcm_format_silence_64(snd_pcm_format_t format);
++uint8_t snd_pcm_format_silence(snd_pcm_format_t format);
++uint16_t snd_pcm_format_silence_16(snd_pcm_format_t format);
++uint32_t snd_pcm_format_silence_32(snd_pcm_format_t format);
++uint64_t snd_pcm_format_silence_64(snd_pcm_format_t format);
+ int snd_pcm_format_set_silence(snd_pcm_format_t format, void *buf, unsigned int samples);
+
+ snd_pcm_sframes_t snd_pcm_bytes_to_frames(snd_pcm_t *pcm, ssize_t bytes);
+Only in alsa-lib-1.1.0/include: pcm.h.orig
+diff -ru alsa-lib-1.1.0.orig/src/pcm/pcm_misc.c alsa-lib-1.1.0/src/pcm/pcm_misc.c
+--- alsa-lib-1.1.0.orig/src/pcm/pcm_misc.c 2015-11-09 09:39:18.000000000 +0200
++++ alsa-lib-1.1.0/src/pcm/pcm_misc.c 2016-02-11 14:28:27.741355826 +0200
+@@ -387,7 +387,7 @@
* \param format Sample format
* \return silence 64 bit word
*/
@@ -9,7 +37,7 @@
{
switch (format) {
case SNDRV_PCM_FORMAT_S8:
-@@ -437,7 +437,7 @@
+@@ -467,7 +467,7 @@
{
union {
float f[2];
@@ -18,7 +46,7 @@
} u;
u.f[0] = u.f[1] = 0.0;
#ifdef SNDRV_LITTLE_ENDIAN
-@@ -450,7 +450,7 @@
+@@ -480,7 +480,7 @@
{
union {
double f;
@@ -27,7 +55,7 @@
} u;
u.f = 0.0;
#ifdef SNDRV_LITTLE_ENDIAN
-@@ -463,7 +463,7 @@
+@@ -493,7 +493,7 @@
{
union {
float f[2];
@@ -36,7 +64,7 @@
} u;
u.f[0] = u.f[1] = 0.0;
#ifdef SNDRV_LITTLE_ENDIAN
-@@ -476,7 +476,7 @@
+@@ -506,7 +506,7 @@
{
union {
double f;
@@ -45,7 +73,7 @@
} u;
u.f = 0.0;
#ifdef SNDRV_LITTLE_ENDIAN
-@@ -509,10 +509,10 @@
+@@ -539,10 +539,10 @@
* \param format Sample format
* \return silence 32 bit word
*/
@@ -58,7 +86,7 @@
}
/**
-@@ -520,10 +520,10 @@
+@@ -550,10 +550,10 @@
* \param format Sample format
* \return silence 16 bit word
*/
@@ -71,7 +99,7 @@
}
/**
-@@ -531,10 +531,10 @@
+@@ -561,10 +561,10 @@
* \param format Sample format
* \return silence 8 bit word
*/
@@ -84,7 +112,7 @@
}
/**
-@@ -550,7 +550,7 @@
+@@ -580,7 +580,7 @@
return 0;
switch (snd_pcm_format_physical_width(format)) {
case 4: {
@@ -93,7 +121,7 @@
unsigned int samples1;
if (samples % 2 != 0)
return -EINVAL;
-@@ -559,13 +559,13 @@
+@@ -589,13 +589,13 @@
break;
}
case 8: {
@@ -110,7 +138,7 @@
if (! silence)
memset(data, 0, samples * 2);
else {
-@@ -575,8 +575,8 @@
+@@ -605,8 +605,8 @@
break;
}
case 24: {
@@ -121,7 +149,7 @@
if (! silence)
memset(data, 0, samples * 3);
else {
-@@ -595,8 +595,8 @@
+@@ -625,8 +625,8 @@
break;
}
case 32: {
@@ -132,7 +160,7 @@
if (! silence)
memset(data, 0, samples * 4);
else {
-@@ -606,8 +606,8 @@
+@@ -636,8 +636,8 @@
break;
}
case 64: {
@@ -143,3 +171,4 @@
if (! silence)
memset(data, 0, samples * 8);
else {
+Only in alsa-lib-1.1.0/src/pcm: pcm_misc.c.orig
diff --git a/main/alsa-lib/alsa-lib_pcm_h.patch b/main/alsa-lib/alsa-lib_pcm_h.patch
deleted file mode 100644
index 1d430da5a9d..00000000000
--- a/main/alsa-lib/alsa-lib_pcm_h.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- alsa-lib-1.0.25/include/pcm.h
-+++ alsa-lib-1.0.25.patched/include/pcm.h
-@@ -33,6 +33,7 @@
- extern "C" {
- #endif
-
-+#include <stdint.h>
- /**
- * \defgroup PCM PCM Interface
- * See the \ref pcm page for more details.
-@@ -941,10 +942,10 @@
- int snd_pcm_format_physical_width(snd_pcm_format_t format); /* in bits */
- snd_pcm_format_t snd_pcm_build_linear_format(int width, int pwidth, int unsignd, int big_endian);
- ssize_t snd_pcm_format_size(snd_pcm_format_t format, size_t samples);
--u_int8_t snd_pcm_format_silence(snd_pcm_format_t format);
--u_int16_t snd_pcm_format_silence_16(snd_pcm_format_t format);
--u_int32_t snd_pcm_format_silence_32(snd_pcm_format_t format);
--u_int64_t snd_pcm_format_silence_64(snd_pcm_format_t format);
-+uint8_t snd_pcm_format_silence(snd_pcm_format_t format);
-+uint16_t snd_pcm_format_silence_16(snd_pcm_format_t format);
-+uint32_t snd_pcm_format_silence_32(snd_pcm_format_t format);
-+uint64_t snd_pcm_format_silence_64(snd_pcm_format_t format);
- int snd_pcm_format_set_silence(snd_pcm_format_t format, void *buf, unsigned int samples);
-
- snd_pcm_sframes_t snd_pcm_bytes_to_frames(snd_pcm_t *pcm, ssize_t bytes);