aboutsummaryrefslogtreecommitdiffstats
path: root/main/apache-mod-fcgid/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/apache-mod-fcgid/APKBUILD')
-rw-r--r--main/apache-mod-fcgid/APKBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/main/apache-mod-fcgid/APKBUILD b/main/apache-mod-fcgid/APKBUILD
index a1eaf4eb3d4..a5b87e5eaef 100644
--- a/main/apache-mod-fcgid/APKBUILD
+++ b/main/apache-mod-fcgid/APKBUILD
@@ -1,32 +1,29 @@
-# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Contributor: Sheila Aman <sheila@vulpine.house>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=apache-mod-fcgid
_pkgreal=mod_fcgid
pkgver=2.3.9
-pkgrel=2
+pkgrel=3
pkgdesc="FastCGI module for Apache 2.x"
url="http://httpd.apache.org/$_pkgreal/"
arch="all"
license="Apache-2.0"
depends="apache2"
makedepends="apache2-dev"
-install=""
subpackages="$pkgname-doc"
source="https://www.apache.org/dist/httpd/mod_fcgid/$_pkgreal-$pkgver.tar.gz
- $_pkgreal.conf
- "
+ $_pkgreal.conf
+ "
+builddir="$srcdir"/$_pkgreal-$pkgver
-_builddir="$srcdir"/$_pkgreal-$pkgver
build() {
- cd "$_builddir"
- ./configure.apxs || return 1
- make || return 1
+ ./configure.apxs
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- install -d "$pkgdir"/var/www/localhost/fcgi-bin || return 1
+ make DESTDIR="$pkgdir" install
+ install -d "$pkgdir"/var/www/localhost/fcgi-bin
install -Dm644 "$srcdir"/$_pkgreal.conf "$pkgdir"/etc/apache2/conf.d/$_pkgreal.conf
rm -fr "$pkgdir"/etc/apache2/original
}