aboutsummaryrefslogtreecommitdiffstats
path: root/main/apg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/apg/APKBUILD')
-rw-r--r--main/apg/APKBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/main/apg/APKBUILD b/main/apg/APKBUILD
index 209509a2b76..6011e20a9e6 100644
--- a/main/apg/APKBUILD
+++ b/main/apg/APKBUILD
@@ -1,26 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apg
pkgver=2.2.3
-pkgrel=5
+pkgrel=7
pkgdesc="Automated Password Generator."
url="https://linux.die.net/man/1/apg" # Original homepage is dead
arch="all"
license="BSD-3-Clause"
# no check provided by upstream
options="!check"
-source="https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}.orig.tar.gz"
+subpackages="$pkgname-doc"
+source="https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_$pkgver.orig.tar.gz"
build() {
- cd "$builddir"
sed -i 's:^#\(CS_LIBS = -lnsl\)$:\1:' Makefile
make
}
package() {
- cd "$builddir"
for i in apg apgbfm; do
install -D -m755 $i "$pkgdir"/usr/bin/$i
- install -D -m644 doc/man/$i.1 "$pkgdir"/usr/man/man1/$i.1
+ install -D -m644 doc/man/$i.1 "$pkgdir"/usr/share/man/man1/$i.1
done
}