aboutsummaryrefslogtreecommitdiffstats
path: root/main/bctoolbox/cmake-bcunit-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/bctoolbox/cmake-bcunit-fix.patch')
-rw-r--r--main/bctoolbox/cmake-bcunit-fix.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/bctoolbox/cmake-bcunit-fix.patch b/main/bctoolbox/cmake-bcunit-fix.patch
index fd3a747640b..af279ebe43f 100644
--- a/main/bctoolbox/cmake-bcunit-fix.patch
+++ b/main/bctoolbox/cmake-bcunit-fix.patch
@@ -1,13 +1,13 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e14e502..9711ea7 100644
+index 6828b3f..b41262f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -98,14 +98,9 @@ if(POLARSSL_FOUND)
+@@ -106,14 +106,9 @@ if(POLARSSL_FOUND)
endif()
if(ENABLE_TESTS_COMPONENT)
-- find_package(BcUnit REQUIRED)
-- cmake_push_check_state(RESET)
+- find_package(BcUnit CONFIG REQUIRED)
+- cmake_push_check_state(RESET)
- list(APPEND CMAKE_REQUIRED_INCLUDES ${BCUNIT_INCLUDE_DIRS})
- list(APPEND CMAKE_REQUIRED_LIBRARIES ${BCUNIT_LIBRARIES})
check_symbol_exists("CU_get_suite" "BCUnit/BCUnit.h" HAVE_CU_GET_SUITE)