aboutsummaryrefslogtreecommitdiffstats
path: root/main/bluez/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/bluez/APKBUILD')
-rw-r--r--main/bluez/APKBUILD110
1 files changed, 51 insertions, 59 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index 78412079421..8c320b7747a 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,18 +1,30 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
-pkgver=5.60
+# Make sure to also update the obexd-enhanced package if updating bluez
+pkgver=5.73
pkgrel=0
pkgdesc="Tools for the Bluetooth protocol stack"
-url="http://www.bluez.org/"
+url="https://www.bluez.org/"
arch="all"
-license="GPL-2.0-or-later"
+license="GPL-2.0-or-later AND BSD-2-Clause AND MIT"
depends="dbus"
replaces="udev"
-makedepends="dbus-dev libusb-compat-dev eudev-dev json-c-dev
- libical-dev readline-dev glib-dev linux-headers
- autoconf automake libtool ell-dev py3-docutils"
+makedepends="
+ dbus-dev
+ ell-dev
+ eudev-dev
+ glib-dev
+ json-c-dev
+ libical-dev
+ libtool
+ linux-headers
+ py3-docutils
+ py3-pygments
+ readline-dev
+ "
subpackages="
+ $pkgname-dbg
$pkgname-dev
$pkgname-doc
$pkgname-libs
@@ -25,7 +37,6 @@ subpackages="
$pkgname-hid2hci
$pkgname-meshctl
$pkgname-obexd
- $pkgname-plugins
$pkgname-zsh-completion
"
source="https://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
@@ -41,26 +52,15 @@ source="https://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
005-hostname-Use-phone-class-for-handhelds.patch
disable-lock-test.patch
fix-endianness.patch
- musl.patch
test-mesh-crypto.patch
- fix-musl.patch
"
-case "$CARCH" in
-# crypto tests assume little-endian
-mips*) options="!check";;
-esac
-
# secfixes:
# 5.54-r0:
# - CVE-2020-0556
-prepare() {
- default_prepare
- autoreconf -vif
-}
-
build() {
+ CFLAGS="$CFLAGS -flto=auto" \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -84,16 +84,20 @@ check() {
}
package() {
- make install DESTDIR="$pkgdir"
+ make DESTDIR="$pkgdir" install install-pluginLTLIBRARIES
+
install -D -m644 src/main.conf "$pkgdir"/etc/bluetooth/main.conf
install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
install -Dm755 "$srcdir"/rfcomm.initd "$pkgdir"/etc/init.d/rfcomm
install -Dm644 "$srcdir"/rfcomm.confd "$pkgdir"/etc/conf.d/rfcomm
- # Fix shebang for the installed binary
- sed 's|^#!/usr/bin/python$|#!/usr/bin/env python3|g' -i test/simple-agent
install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
+ install -Dm755 tools/btmgmt -t "$pkgdir"/usr/bin/
+ install -Dm755 attrib/gatttool -t "$pkgdir"/usr/bin/
+
+ install -Dm644 "$srcdir"/org.bluez.obex.service \
+ "$pkgdir"/usr/share/dbus-1/services/org.bluez.obex.service
# Autostart mpris-proxy to pass through MPRIS control over BlueZ
install -Dm644 "$srcdir"/mpris-proxy.desktop -t "$pkgdir"/etc/xdg/autostart/
@@ -101,60 +105,50 @@ package() {
btmgmt() {
pkgdesc="Bluez tool for the Bluetooth Management API"
- install -Dm755 "$builddir"/tools/btmgmt "$subpkgdir"/usr/bin/btmgmt
+ amove usr/bin/btmgmt
}
btmon() {
pkgdesc="Bluez bluetooth monitor"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/btmon "$subpkgdir"/usr/bin/
+ amove usr/bin/btmon
}
cups() {
pkgdesc="Bluez backend for CUPS"
- mkdir -p "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/cups "$subpkgdir"/usr/lib/
+ amove usr/lib/cups
}
hid2hci() {
pkgdesc="Put HID proxying bluetooth HCI's into HCI mode"
replaces="bluez"
- mkdir -p "$subpkgdir"
- mv "$pkgdir"/lib "$subpkgdir"/
+ amove /lib
}
deprecated() {
pkgdesc="Deprecated bluetooth tools"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/ciptool \
- "$builddir"/attrib/gatttool \
- "$pkgdir"/usr/bin/hciattach \
- "$pkgdir"/usr/bin/hciconfig \
- "$pkgdir"/usr/bin/hcidump \
- "$pkgdir"/usr/bin/hcitool \
- "$pkgdir"/usr/bin/rfcomm \
- "$pkgdir"/usr/bin/sdptool \
- "$subpkgdir"/usr/bin/
+ amove \
+ usr/bin/ciptool \
+ usr/bin/gatttool \
+ usr/bin/hciattach \
+ usr/bin/hciconfig \
+ usr/bin/hcidump \
+ usr/bin/hcitool \
+ usr/bin/rfcomm \
+ usr/bin/sdptool
}
meshctl() {
pkgdesc="Bluez tool for interacting with bluetooth mesh networks"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/meshctl "$subpkgdir"/usr/bin/
+ amove usr/bin/meshctl
}
obexd() {
pkgdesc="Bluez OBEX daemon"
- mkdir -p "$subpkgdir"/usr/lib/bluetooth
- mv "$pkgdir"/usr/lib/bluetooth/obexd "$subpkgdir"/usr/lib/bluetooth
- install -Dm644 "$srcdir"/org.bluez.obex.service \
- "$subpkgdir"/usr/share/dbus-1/services/org.bluez.obex.service
-}
-
-plugins() {
- pkgdesc="Bluez plugins (PS3 Sixaxis controller)"
- cd "$builddir"
- make DESTDIR="$subpkgdir" install-pluginLTLIBRARIES
+ provides="obexd"
+ provider_priority=100
+ amove \
+ usr/lib/bluetooth/obexd \
+ usr/share/dbus-1/services/org.bluez.obex.service
}
openrc() {
@@ -183,20 +177,18 @@ openrc() {
}
sha512sums="
-069e054360b4ab72f1daa033572f0fd822fb0f47e52069f4f3dcdfecfa312b9a5366cc04967e639aef39b980c0e1007389f1ee757e7c3bae43a5e66f8ed21a6b bluez-5.60.tar.xz
-fc43c78ed248ea412529eed5ae8bb47bacca9bf5b3b10de121ddd4e792c85893561a88be4aa2c6318106e5d2146a721445152d44fa60ca257ca0b4eb87318c1e bluetooth.initd
+20090da036d3d614706b14a757b02acf138859d8f0476aa7f68d57635dfb3632ce7d8bb3456320904d72333d1314a5fe14dcb8ece307e6d31ce6d2d516de25e8 bluez-5.73.tar.xz
+5442f4f489718e51c50611c143803f2cc99e540b55a72af20ea2921b256774a6c7c5e273f2bedb745753d8c67d3fb7c938750fb48feac7460b32bd1cca029a28 bluetooth.initd
8d7b7c8938a2316ce0a855e9bdf1ef8fcdf33d23f4011df828270a088b88b140a19c432e83fef15355d0829e3c86be05b63e7718fef88563254ea239b8dc12ac rfcomm.initd
a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b3484120ee28fdd21240bd456a4f5d706262700924bd2e9a0972fb rfcomm.confd
d6766a4992ed4141569d6d82a802a771a5cb4c08873bfb0fdbedeea4d738bf9b56d9e0452ec19b7635418b1af4ab9b1735692043d629cbed3ce0eda6f51e1c6f org.bluez.obex.service
-78e4c1e1f3b3b31a8622f92bacb6cd61b7795c2371457cf6baa74c04d38683780a0ee9ad0687a9af74b1af85a4d330f183d01d8768e5899adbaa7644956b58a3 mpris-proxy.desktop
+72f9bc6cafe910ed7d105d4f3a537b16cd897622b2391ea545e6a302fcce2ed79e490e2841c6290aa1290489870a67638d71b0de5bc57f9d650e2248d9e4f0a4 mpris-proxy.desktop
73202915fda01d420b2864da77b1c25af5a55c815e9be6546400a0940bfb6097d83322790bc22a80ec0fcd557144fdd1877e243a79285a7f040ff96ba3600b94 001-bcm43xx-Add-bcm43xx-3wire-variant.patch
d5fd1c962bd846eaa6fff879bab85f753eb367d514f82d133b5d3242e1da989af5eddd942c60a87d5b67783e060f91bfa0f74fb1e8e6699cdee6e5bbe6a431ea 002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
784e9644c8de4e2693e2eeed988a245608b8cb14e1fc0dff8795c60c527b2e8d0c87862cfbfd6b850b47ae80cdf993a5ed3f477078ea1068fd7374899c7a1a77 003-Increase-firmware-load-timeout-to-30s.patch
-42ac04044a8c66e07487598b3a75ef52efc32999ebce4e7c63f6198e2f603f4a1442e74600e43a0938cb4f52d4db0298aa99050b18144b84990cda71748e9de5 004-Move-the-43xx-firmware-into-lib-firmware.patch
+6d864d893aaf08d7a04f5cb27a6b2767c361cd41e479f27ed84d9fbbd2677298c15e31161a614af098df8faf3da54b71cf315fe8e9a9a2f671e4720c7b8b457b 004-Move-the-43xx-firmware-into-lib-firmware.patch
ac635f9bca0e983835940572eb1b96ad70cf60fb84d5b0fde38c76ea6d1b13ef7d9adf81468b9fed779c890ab69dd5dfabf21970bff018466115c424668b82fb 005-hostname-Use-phone-class-for-handhelds.patch
04c4889372c8e790bb338dde7ffa76dc32fcf7370025c71b9184fcf17fd01ade4a6613d84d648303af3bbc54043ad489f29fc0cd4679ec8c9029dcb846d7e026 disable-lock-test.patch
-118d55183860f395fc4bdc93efffb13902ebf7388cad722b9061cd2860d404333e500af521741c3d92c0f8a161f6810348fbeb6682e49c372383f417aed8c76a fix-endianness.patch
-641e425333d269833eed624edec0e29cba04bb0ff6570f6afda178a164fc2bb77456fa88957fe49f36000d3601ac00bb7ba089400977c1577e9c226e74baa3d6 musl.patch
-9c57bb1abf1b4927441a2a25c3c2599b0da82850e6b945d09e824e25be7c7efa99e54999cf5b799a1093303202badf08833cc4ccb36203901dfa516031ea8eb0 test-mesh-crypto.patch
-2e92639512c11e69d3c47e222a012b4f58fa7727d18b3639130e8fe91654773b1205ddbe650efe49a26ec41a64d39ddba2806503272e09252c51d194e3ced33d fix-musl.patch
+2f54da5e77893d1d8b7164ddac5561a9e536c2b93b1d33dcbd97e74c0fd45588f1f50dc1d9d8519297871e3a376948082a2e45e27d823ec81cdedecd8dba3f0c fix-endianness.patch
+b5d6f7d2df755a9b8cffaeef13d232ba1bab27544bc59e2299bbd6a8017768cf7781f3ca65e430a149a26f0b30ae74b8510529ce161705bb6f41ae512cc2dbac test-mesh-crypto.patch
"