aboutsummaryrefslogtreecommitdiffstats
path: root/main/botan/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/botan/APKBUILD')
-rw-r--r--main/botan/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/main/botan/APKBUILD b/main/botan/APKBUILD
index 2786b3b25ca..35b0f776b83 100644
--- a/main/botan/APKBUILD
+++ b/main/botan/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: tcely <tcely@users.noreply.github.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=botan
-pkgver=2.19.2
-pkgrel=1
+pkgver=2.19.4
+pkgrel=0
pkgdesc="Crypto and TLS for C++11"
url="https://botan.randombit.net/"
arch="all"
@@ -28,7 +28,8 @@ builddir="$srcdir/Botan-$pkgver"
# - CVE-2018-9127
case $CARCH in
- ppc64le|aarch64|armhf|armv7) options="$options !check" ;; # 3 tests timeout
+ arm*|riscv64)
+ options="$options !check" ;; # several tests fail
esac
build() {
@@ -55,9 +56,11 @@ check() {
package() {
make DESTDIR="$pkgdir" install
+ # botan3 keeps the main name
+ mv "$pkgdir"/usr/bin/botan "$pkgdir"/usr/bin/botan2
rm -rf "$pkgdir"/usr/lib/python*
}
sha512sums="
-52b9c80a240457e46a299480338472f7d0c0b56df7b1709fdef52c5be3afca5b474fe143801c9a332ae884eaf033e60461c9d3e0b2f7b069f4fe8b4c45932abf Botan-2.19.2.tar.xz
+2fab4347367703dce8302b7710698ed228c6cc6dd609c39829ba17ad580407ed40d822862d467aa7aea4bfd633c1f1d1c0d437e86376f453845cc609596335d8 Botan-2.19.4.tar.xz
"