aboutsummaryrefslogtreecommitdiffstats
path: root/main/botan/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/botan/APKBUILD')
-rw-r--r--main/botan/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/main/botan/APKBUILD b/main/botan/APKBUILD
index 938831a6764..35b0f776b83 100644
--- a/main/botan/APKBUILD
+++ b/main/botan/APKBUILD
@@ -1,13 +1,13 @@
# Contributor: tcely <tcely@users.noreply.github.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=botan
-pkgver=2.19.1
-pkgrel=2
+pkgver=2.19.4
+pkgrel=0
pkgdesc="Crypto and TLS for C++11"
url="https://botan.randombit.net/"
arch="all"
license="BSD-2-Clause"
-depends_dev="boost-dev bzip2-dev openssl1.1-compat-dev sqlite-dev xz-dev zlib-dev"
+depends_dev="boost-dev bzip2-dev sqlite-dev xz-dev zlib-dev"
makedepends="$depends_dev python3"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="https://botan.randombit.net/releases/Botan-$pkgver.tar.xz"
@@ -28,7 +28,8 @@ builddir="$srcdir/Botan-$pkgver"
# - CVE-2018-9127
case $CARCH in
- ppc64le|aarch64|armhf|armv7) options="$options !check" ;; # 3 tests timeout
+ arm*|riscv64)
+ options="$options !check" ;; # several tests fail
esac
build() {
@@ -41,7 +42,6 @@ build() {
--with-bzip2 \
--with-lzma \
--with-openmp \
- --with-openssl \
--with-sqlite3 \
--with-zlib \
--with-os-feature=getrandom \
@@ -56,9 +56,11 @@ check() {
package() {
make DESTDIR="$pkgdir" install
+ # botan3 keeps the main name
+ mv "$pkgdir"/usr/bin/botan "$pkgdir"/usr/bin/botan2
rm -rf "$pkgdir"/usr/lib/python*
}
sha512sums="
-e604be0e7e82da89e3e1949d3035a87dc63314bd9854d5fe5129ccb3ed5bc78edb0406c7f8ad1a152b59a63b6d98ba207a0851a08428c3452cce794614b5eef5 Botan-2.19.1.tar.xz
+2fab4347367703dce8302b7710698ed228c6cc6dd609c39829ba17ad580407ed40d822862d467aa7aea4bfd633c1f1d1c0d437e86376f453845cc609596335d8 Botan-2.19.4.tar.xz
"