summaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD4
-rw-r--r--main/busybox/busybox-1.18.2-wget.patch20
2 files changed, 23 insertions, 1 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index 273a631e4a7..99b1f2ca4ae 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.18.2
-pkgrel=1
+pkgrel=2
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -13,6 +13,7 @@ triggers="busybox.trigger:/bin /usr/bin /sbin /usr/sbin /lib/modules/*"
source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
$pkgname-1.11.1-bb.patch
busybox-uname-is-not-gnu.patch
+ busybox-1.18.2-wget.patch
busyboxconfig"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -72,4 +73,5 @@ static() {
md5sums="69a82091e5710b72db5ce0e14e7c0cd7 busybox-1.18.2.tar.bz2
4c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch
b5375210f13fd6e1ca61a565e8fabd35 busybox-uname-is-not-gnu.patch
+d45bc3a7a8d5a903c0c3cb561c4bd1b1 busybox-1.18.2-wget.patch
181310149cad8fce22aba96220cbbd38 busyboxconfig"
diff --git a/main/busybox/busybox-1.18.2-wget.patch b/main/busybox/busybox-1.18.2-wget.patch
new file mode 100644
index 00000000000..8c28eea65e3
--- /dev/null
+++ b/main/busybox/busybox-1.18.2-wget.patch
@@ -0,0 +1,20 @@
+--- busybox-1.18.2/networking/wget.c
++++ busybox-1.18.2.mod/networking/wget.c
+@@ -137,7 +137,7 @@
+ ret = fread(p, 1, nmemb, stream);
+ p += ret;
+ nmemb -= ret;
+- } while (nmemb && ferror(stream) && errno == EINTR);
++ } while (nmemb && ferror(stream) && (errno == EINTR || errno == EAGAIN));
+
+ return p - (char*)ptr;
+ }
+@@ -152,7 +152,7 @@
+ clearerr(stream);
+ errno = 0;
+ ret = fgets(s, size, stream);
+- } while (ret == NULL && ferror(stream) && errno == EINTR);
++ } while (ret == NULL && ferror(stream) && (errno == EINTR || errno == EAGAIN));
+
+ return ret;
+ }