summaryrefslogtreecommitdiffstats
path: root/main/cgit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/cgit/APKBUILD')
-rw-r--r--main/cgit/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/main/cgit/APKBUILD b/main/cgit/APKBUILD
new file mode 100644
index 00000000000..d7578539c82
--- /dev/null
+++ b/main/cgit/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=cgit
+pkgver=0.8.2.1
+pkgrel=1
+_gitver=1.6.2.4
+pkgdesc="a fast webinterface for git"
+url="http://hjemli.net/git/cgit"
+license=GPL-2
+makedepends="openssl-dev zlib-dev"
+depends="uclibc openssl zlib"
+source="
+ http://hjemli.net/git/cgit/snapshot/$pkgname-$pkgver.tar.gz
+ http://www.kernel.org/pub/software/scm/git/git-$_gitver.tar.bz2
+ "
+
+build() {
+ local makeopts="NO_ICONV=YesPlease NO_CURL=YesPlease"
+ cd "$srcdir/$pkgname-$pkgver"
+ rm -rf git
+ ln -s ../git-$_gitver git
+ make $makeopts || return 1
+ make $makeopts DESTDIR="$pkgdir" \
+ CGIT_SCRIPT_PATH=/usr/share/webapps/cgit \
+ install
+ ln -s cgit.cgi "$pkgdir"/usr/share/webapps/cgit/cgit
+}
+
+md5sums="12f5468a948be40c275445253e73d309 cgit-0.8.2.1.tar.gz
+c24d796879bb09e1cc5545bf3a3d7cf6 git-1.6.2.4.tar.bz2"