aboutsummaryrefslogtreecommitdiffstats
path: root/main/cgit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/cgit/APKBUILD')
-rw-r--r--main/cgit/APKBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/main/cgit/APKBUILD b/main/cgit/APKBUILD
index 6bbfe6fd24b..9bccf905f5a 100644
--- a/main/cgit/APKBUILD
+++ b/main/cgit/APKBUILD
@@ -1,18 +1,19 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cgit
-pkgver=1.2.1
-pkgrel=1
-_gitver=2.18.0
+pkgver=1.2.3
+pkgrel=5
+_gitver=2.25.1
pkgdesc="A fast webinterface for git"
url="https://git.zx2c4.com/cgit/"
arch="all"
-license="GPL-2.0-only"
-makedepends="openssl-dev zlib-dev lua5.3-dev asciidoc"
+license="GPL-2.0-or-later"
+makedepends="openssl-dev>3 zlib-dev lua5.3-dev asciidoc"
subpackages="$pkgname-doc"
-source="http://git.zx2c4.com/$pkgname/snapshot/$pkgname-$pkgver.tar.xz
+source="http://git.zx2c4.com/cgit/snapshot/cgit-$pkgver.tar.xz
https://www.kernel.org/pub/software/scm/git/git-$_gitver.tar.gz
"
+options="!check"
_makeopts="NO_ICONV=YesPlease
NO_GETTEXT=YesPlease
@@ -22,10 +23,7 @@ _makeopts="NO_ICONV=YesPlease
LUA_PKGCONFIG=lua5.3
prefix=/usr"
-builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- cd "$builddir"
-
# check that upstream git ver corresponds with our
local _ver=$(awk -F'[ \t]*=[ \t]*' '/^GIT_VER/ { print $2 }' Makefile)
if [ "$_ver" != "$_gitver" ]; then
@@ -40,17 +38,15 @@ prepare() {
}
build() {
- cd "$builddir"
make $_makeopts all doc-man
}
package() {
- cd "$builddir"
make $_makeopts DESTDIR="$pkgdir" \
CGIT_SCRIPT_PATH=/usr/share/webapps/cgit \
install install-man
ln -s cgit.cgi "$pkgdir"/usr/share/webapps/cgit/cgit
}
-sha512sums="c7380df9afbc3735ef9e4f196f4f5bbd26cf52e473fa6f435e7d0c00dc295cc8de6bee6bfb1857144025c8591d41a6a74efb1af551e8610848d90ac40fcfab36 cgit-1.2.1.tar.xz
-ccbcb0e165044698aa0308e579745bb68701ac11335b795cc733d857d642f8dbd6f998253f6edb6f1cb93bd32d41c68d964cda138cd44c0b7bcbbdbb5117264f git-2.18.0.tar.gz"
+sha512sums="58f9bb644b07be49dc51f3ef30a3d0e53699cede3c06b1d6920f3874fe846c83dd2589632aa84357b70ea2d60272448409aa1b892f405d14dd6745f5559b4504 cgit-1.2.3.tar.xz
+1c955f25da190c78750542a2fc81710aed3cd1fa4933b8734c81b00c07bfbf5b1379b555001340d55cdb2b996dd79b116bbfcfc0106940f06676f017907a599c git-2.25.1.tar.gz"