summaryrefslogtreecommitdiffstats
path: root/main/consolekit
diff options
context:
space:
mode:
Diffstat (limited to 'main/consolekit')
-rw-r--r--main/consolekit/0001-busybox-reboot-and-poweroff-support.patch41
-rw-r--r--main/consolekit/APKBUILD15
2 files changed, 52 insertions, 4 deletions
diff --git a/main/consolekit/0001-busybox-reboot-and-poweroff-support.patch b/main/consolekit/0001-busybox-reboot-and-poweroff-support.patch
new file mode 100644
index 00000000000..7fa0e35759b
--- /dev/null
+++ b/main/consolekit/0001-busybox-reboot-and-poweroff-support.patch
@@ -0,0 +1,41 @@
+From 5e557dd212657f7e75a0c4bd70d11ca06ccb3f84 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 4 Apr 2011 18:46:25 +0000
+Subject: [PATCH] busybox reboot and poweroff support
+
+---
+ tools/linux/ck-system-restart | 3 +++
+ tools/linux/ck-system-stop | 3 +++
+ 2 files changed, 6 insertions(+), 0 deletions(-)
+
+diff --git a/tools/linux/ck-system-restart b/tools/linux/ck-system-restart
+index 8e0664e..5cabb3d 100755
+--- a/tools/linux/ck-system-restart
++++ b/tools/linux/ck-system-restart
+@@ -7,6 +7,9 @@ if [ -x "/sbin/shutdown" ] ; then
+ elif [ -x "/usr/sbin/shutdown" ] ; then
+ /usr/sbin/shutdown -r now
+ exit $?
++elif [ -x "/sbin/reboot" ]; then
++ /sbin/reboot
++ exit $?
+ else
+ exit 1
+ fi
+diff --git a/tools/linux/ck-system-stop b/tools/linux/ck-system-stop
+index e26bca3..a0be3ac 100755
+--- a/tools/linux/ck-system-stop
++++ b/tools/linux/ck-system-stop
+@@ -7,6 +7,9 @@ if [ -x "/sbin/shutdown" ] ; then
+ elif [ -x "/usr/sbin/shutdown" ] ; then
+ /usr/sbin/shutdown -h now
+ exit $?
++elif [ -x "/sbin/poweroff" ] ; then
++ /sbin/poweroff
++ exit $?
+ else
+ exit 1
+ fi
+--
+1.7.4.2
+
diff --git a/main/consolekit/APKBUILD b/main/consolekit/APKBUILD
index ba9a93fab88..b5ff6878cbe 100644
--- a/main/consolekit/APKBUILD
+++ b/main/consolekit/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=consolekit
pkgver=0.4.4
-pkgrel=0
+pkgrel=1
pkgdesc="Framework for defining and tracking users, login sessions, and seats"
url="http://www.freedesktop.org/wiki/Software/ConsoleKit"
arch="all"
@@ -11,13 +11,19 @@ makedepends="polkit-dev zlib-dev libx11-dev dbus-glib-dev"
depends_dev="dbus-dev"
install=
subpackages="$pkgname-dev $pkgname-doc"
-source="http://www.freedesktop.org/software/ConsoleKit/dist/ConsoleKit-$pkgver.tar.bz2"
+source="http://www.freedesktop.org/software/ConsoleKit/dist/ConsoleKit-$pkgver.tar.bz2
+ 0001-busybox-reboot-and-poweroff-support.patch
+ "
_builddir="$srcdir"/ConsoleKit-$pkgver
prepare() {
cd "$_builddir"
- # apply patches here
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -36,4 +42,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="b57eb18eae8c4d3631d5f4f030218a29 ConsoleKit-0.4.4.tar.bz2"
+md5sums="b57eb18eae8c4d3631d5f4f030218a29 ConsoleKit-0.4.4.tar.bz2
+acc4f44190cd677f95fd529d528c9cef 0001-busybox-reboot-and-poweroff-support.patch"