summaryrefslogtreecommitdiffstats
path: root/main/cramfs
diff options
context:
space:
mode:
Diffstat (limited to 'main/cramfs')
-rw-r--r--main/cramfs/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/main/cramfs/APKBUILD b/main/cramfs/APKBUILD
new file mode 100644
index 00000000000..e40e57c2cc5
--- /dev/null
+++ b/main/cramfs/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Natanael Copa <natanael.copa@gmail.com>
+pkgname=cramfs
+pkgver=1.1
+pkgrel=0
+pkgdesc="Linux filesystem designed to be simple, small, and to compress things well"
+arch=""
+url="http://sourceforge.net/projects/cramfs/"
+license='GPL'
+depends="uclibc zlib"
+makedepends="zlib-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make CFLAGS="$CFLAGS" || return 1
+ install -d "$pkgdir"/sbin
+ install mkcramfs cramfsck "$pkgdir"/sbin
+}
+
+md5sums="d3912b9f7bf745fbfea68f6a9b9de30f cramfs-1.1.tar.gz"