aboutsummaryrefslogtreecommitdiffstats
path: root/main/cryptsetup/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/cryptsetup/APKBUILD')
-rw-r--r--main/cryptsetup/APKBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/main/cryptsetup/APKBUILD b/main/cryptsetup/APKBUILD
index 03672d7a8eb..3ffefa0c066 100644
--- a/main/cryptsetup/APKBUILD
+++ b/main/cryptsetup/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cryptsetup
-pkgver=2.5.0
-pkgrel=1
+pkgver=2.7.2
+pkgrel=0
pkgdesc="Userspace setup tool for transparent encryption of block devices using the Linux 2.6 cryptoapi"
url="https://gitlab.com/cryptsetup/cryptsetup"
arch="all"
-license="GPL-2.0-or-later WITH OpenSSL-Exception"
+license="GPL-2.0-or-later WITH cryptsetup-OpenSSL-exception"
makedepends_build="asciidoctor bash coreutils"
makedepends_host="
argon2-dev
@@ -22,8 +22,6 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-openrc"
source="https://www.kernel.org/pub/linux/utils/cryptsetup/v${pkgver%.*}/cryptsetup-$pkgver.tar.gz
dmcrypt.initd
dmcrypt.confd
-
- flush-stdout.patch
"
# secfixes:
@@ -35,6 +33,9 @@ source="https://www.kernel.org/pub/linux/utils/cryptsetup/v${pkgver%.*}/cryptset
build() {
# Disable support for external tokens since it requires
# dlvsym(3) which is a GNU extension and not available in musl.
+ if [ -z "$BOOTSTRAP" ]; then
+ export CFLAGS="$CFLAGS -flto=auto"
+ fi
./configure \
--build="$CBUILD" \
--host="$CHOST" \
@@ -65,17 +66,25 @@ package() {
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
install -m644 README.md FAQ.md docs/v$pkgver-ReleaseNotes \
-t "$pkgdir"/usr/share/doc/$pkgname/
+
+ # mandoc does not support the .so directive which replace the
+ # content of a man page with that of another. cryptsetup uses
+ # several man pages which just contain an .so directive. Replace
+ # these with symlinks to make them work by default in mandoc.
+ #
+ # See https://inbox.vuxu.org/mandoc-tech/20101024194129.GJ20876@iris.usta.de/#r
+ grep -l -R '^\.so ' "$pkgdir"/usr/share/man | \
+ xargs awk '/^\.so/ { system("ln -fs " $2 " " FILENAME) }'
}
libs() {
pkgdesc="Cryptsetup shared library"
- mkdir -p "$subpkgdir"
- mv "$pkgdir"/lib "$subpkgdir"/
+
+ amove /lib
}
sha512sums="
-f457168292ae9fadc34d709494818aee3f18b56bdf5fcff0b2a5ae0b554031ce888d01cd126ca7aa915fcdcb00de6afed2fdb25bbbd690aa8bfcaafa516ade93 cryptsetup-2.5.0.tar.gz
-a3ca3e648749136ee724692b61488cd855f118eb93435942c2b04964a34fe49d0f0da4ef64cd2531c1c0f650e77808cf5d802789fd7664398248ead668bb35e5 dmcrypt.initd
+ba8f4aeda997242372e3e2eb4527babfd0ebf31fd28a2e894d7648d37b9a7a1845fb286f2769b3b3741340d68cdd7877d2f9be743bb3e4db9c053accf4640093 cryptsetup-2.7.2.tar.gz
+2a7abe572809d070579ceaeeeb25f050d32408756c1086ddf0e16f41bde239cfb1b8b95e1009362188faccd8060926cbf48a04714e8ddbb09ae3c903f6a490c8 dmcrypt.initd
74422d5e1614b43af894ea01da1ea80d805ec7f77981cbb80a6b1a4becad737a8825d7269812499095a7f50d39fa7da5bf4e4edae63529b1fe87b9176943a733 dmcrypt.confd
-529187851def5fbc08e995eba90d3f013f1cf8469dcb9344f83d1e3c73c71467ca4ed62c8282ec27ebfa30ccc33653fdd1aea8d1d80e1ac4293d51865c9a6200 flush-stdout.patch
"