aboutsummaryrefslogtreecommitdiffstats
path: root/main/cunit/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/cunit/APKBUILD')
-rw-r--r--main/cunit/APKBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/main/cunit/APKBUILD b/main/cunit/APKBUILD
index ae369ebcb62..39f5e5c4d98 100644
--- a/main/cunit/APKBUILD
+++ b/main/cunit/APKBUILD
@@ -4,20 +4,19 @@ pkgname=cunit
_pkgname=CUnit
pkgver=2.1.3
_pkgver=${pkgver%.*}-${pkgver##*.}
-pkgrel=2
+pkgrel=7
pkgdesc="Automated testing framework for C"
-url="http://cunit.sourceforge.net/"
+url="https://cunit.sourceforge.net/"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
makedepends="automake autoconf libtool bash"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://downloads.sourceforge.net/project/$pkgname/$_pkgname/$_pkgver/$_pkgname-$_pkgver.tar.bz2
+source="https://downloads.sourceforge.net/project/cunit/$_pkgname/$_pkgver/$_pkgname-$_pkgver.tar.bz2
path-makefile.patch"
builddir="$srcdir/$_pkgname-$_pkgver"
prepare() {
default_prepare
- cd "$builddir"
libtoolize --force --copy
aclocal
autoheader
@@ -28,7 +27,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -46,12 +44,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}