aboutsummaryrefslogtreecommitdiffstats
path: root/main/curl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/curl/APKBUILD')
-rw-r--r--main/curl/APKBUILD119
1 files changed, 96 insertions, 23 deletions
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index 4422481f24d..b434ea1ec7e 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -8,23 +8,91 @@
# this aport from arch=all WILL be reverted.
pkgname=curl
-pkgver=7.80.0
+pkgver=8.7.1
pkgrel=0
pkgdesc="URL retrival utility and library"
url="https://curl.se/"
arch="all"
-license="MIT"
+license="curl"
depends="ca-certificates"
-depends_dev="openssl1.1-compat-dev nghttp2-dev zlib-dev brotli-dev"
+depends_dev="
+ brotli-dev
+ c-ares-dev
+ libidn2-dev
+ libpsl-dev
+ nghttp2-dev
+ openssl-dev>3
+ zlib-dev
+ zstd-dev
+ "
checkdepends="nghttp2 python3"
makedepends_host="$depends_dev"
-makedepends_build="autoconf automake groff libtool perl"
+makedepends_build="groff perl"
subpackages="$pkgname-dbg $pkgname-static $pkgname-doc $pkgname-dev libcurl"
+[ -z "$BOOTSTRAP" ] && subpackages="$subpackages $pkgname-zsh-completion $pkgname-fish-completion"
source="https://curl.se/download/curl-$pkgver.tar.xz"
options="net" # Required for running tests
[ -n "$BOOTSTRAP" ] && options="$options !check" # remove python3 dependency
# secfixes:
+# 8.7.1-r0:
+# - CVE-2024-2004
+# - CVE-2024-2379
+# - CVE-2024-2398
+# - CVE-2024-2466
+# 8.6.0-r0:
+# - CVE-2024-0853
+# 8.5.0-r0:
+# - CVE-2023-46218
+# - CVE-2023-46219
+# 8.4.0-r0:
+# - CVE-2023-38545
+# - CVE-2023-38546
+# 8.3.0-r0:
+# - CVE-2023-38039
+# 8.1.0-r0:
+# - CVE-2023-28319
+# - CVE-2023-28320
+# - CVE-2023-28321
+# - CVE-2023-28322
+# 8.0.0-r0:
+# - CVE-2023-27533
+# - CVE-2023-27534
+# - CVE-2023-27535
+# - CVE-2023-27536
+# - CVE-2023-27537
+# - CVE-2023-27538
+# 7.88.0-r0:
+# - CVE-2023-23914
+# - CVE-2023-23915
+# - CVE-2023-23916
+# 7.87.0-r0:
+# - CVE-2022-43551
+# - CVE-2022-43552
+# 7.86.0-r0:
+# - CVE-2022-32221
+# - CVE-2022-35260
+# - CVE-2022-42915
+# - CVE-2022-42916
+# 7.85.0-r0:
+# - CVE-2022-35252
+# 7.84.0-r0:
+# - CVE-2022-32205
+# - CVE-2022-32206
+# - CVE-2022-32207
+# - CVE-2022-32208
+# 7.83.1-r0:
+# - CVE-2022-27778
+# - CVE-2022-27779
+# - CVE-2022-27780
+# - CVE-2022-27781
+# - CVE-2022-27782
+# - CVE-2022-30115
+# 7.83.0-r0:
+# - CVE-2022-22576
+# - CVE-2022-27774
+# - CVE-2022-27775
+# - CVE-2022-27776
# 7.79.0-r0:
# - CVE-2021-22945
# - CVE-2021-22946
@@ -118,51 +186,56 @@ options="net" # Required for running tests
# 0:
# - CVE-2021-22897
-prepare() {
- default_prepare
- autoreconf -vfi
-}
-
build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
+ --enable-ares \
--enable-ipv6 \
--enable-unix-sockets \
--enable-static \
- --with-openssl \
- --without-libidn \
- --without-libidn2 \
+ --with-libidn2 \
--with-nghttp2 \
+ --with-openssl \
+ --with-zsh-functions-dir \
+ --with-fish-functions-dir \
--disable-ldap \
--with-pic \
+ --enable-websockets \
--without-libssh2 # https://bugs.alpinelinux.org/issues/10222
make
+
+ # generation of completions is not supported when cross-compiling.
+ if [ -z "$BOOTSTRAP" ]; then
+ make -C scripts/
+ fi
}
check() {
- make -C tests nonflaky-test
+ make -C tests
+ make -j1 -C tests TFLAGS="-j$JOBS" nonflaky-test
}
package() {
+ # depends on exactly the same build of libcurl
+ depends="libcurl=$pkgver-r$pkgrel"
+
make install DESTDIR="$pkgdir"
+ if [ -z "$BOOTSTRAP" ]; then
+ install -Dm644 scripts/_curl -t \
+ "$pkgdir"/usr/share/zsh/site-functions/
+ install -Dm644 scripts/curl.fish -t \
+ "$pkgdir"/usr/share/fish/vendor_completions.d/
+ fi
}
libcurl() {
pkgdesc="The multiprotocol file transfer library"
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/lib "$subpkgdir"/usr
-}
-
-static() {
- pkgdesc="$pkgdesc (static library)"
-
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
+ amove usr/lib
}
sha512sums="
-e04ddd74b0d5b3607a29bcf5d379d83a01c7dffa4ad3e2f25d8c85a3df7dbdb0625b0df1f04f02351695674502828e0e17e8b46c889cbf1e43f86d6e6dd716ab curl-7.80.0.tar.xz
+5bbde9d5648e9226f5490fa951690aaf159149345f3a315df2ba58b2468f3e59ca32e8a49734338afc861803a4f81caac6d642a4699b72c6310ebfb1f618aad2 curl-8.7.1.tar.xz
"