aboutsummaryrefslogtreecommitdiffstats
path: root/main/cython/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/cython/APKBUILD')
-rw-r--r--main/cython/APKBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/main/cython/APKBUILD b/main/cython/APKBUILD
index 36c118f954a..52d6808e055 100644
--- a/main/cython/APKBUILD
+++ b/main/cython/APKBUILD
@@ -2,34 +2,34 @@
# Contributor: Oleg Titov <oleg.titov@gmail.com>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=cython
-pkgver=0.29.22
-pkgrel=2
+pkgver=3.0.10
+pkgrel=0
pkgdesc="Cython is an optimising static compiler for both the Python & the extended Cython programming languages."
url="https://cython.org/"
arch="all"
license="Apache-2.0"
-makedepends="py3-setuptools python3-dev"
+makedepends="py3-gpep517 py3-setuptools py3-wheel python3-dev"
depends="python3"
-subpackages="cython-doc"
+subpackages="cython-pyc cython-doc"
source="cython-$pkgver.tar.gz::https://github.com/cython/cython/archive/$pkgver.tar.gz"
-# compatible fix for removing dev subpkg from apkbuild
-# cython is not a library but a compiler and does not need a dev subpackage
-provides=cython-dev
-
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
check() {
- python3 runtests.py -j${JOBS:-$(nproc)}
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 runtests.py -j${JOBS:-$(nproc)}
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
install -Dm 644 LICENSE.txt "$pkgdir/usr/share/licenses/cython/license"
install -Dm 644 README.rst "$pkgdir/usr/share/doc/cython/readme.rst"
}
-sha512sums="b7f22112678f159bf1d0ad5fe4f7c103e96f240bab4d9dc07edd7c2f66a9887b9af72b32f1d5886361b48d428bc2b9499d3c5b59ce5af1068f20a26549783dd6 cython-0.29.22.tar.gz"
+sha512sums="
+97aa831cea96c1f3c51653c51fadb0aea8bdfdb076a2c898862637f52b826bcb9162d1b7aade3304c5650d0b894cb1083052f036365d79cd3d390e0486b33ac5 cython-3.0.10.tar.gz
+"