aboutsummaryrefslogtreecommitdiffstats
path: root/main/cython/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/cython/APKBUILD')
-rw-r--r--main/cython/APKBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/main/cython/APKBUILD b/main/cython/APKBUILD
index 8fdabff4f00..52d6808e055 100644
--- a/main/cython/APKBUILD
+++ b/main/cython/APKBUILD
@@ -2,38 +2,34 @@
# Contributor: Oleg Titov <oleg.titov@gmail.com>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=cython
-pkgver=0.29.24
-pkgrel=1
+pkgver=3.0.10
+pkgrel=0
pkgdesc="Cython is an optimising static compiler for both the Python & the extended Cython programming languages."
url="https://cython.org/"
arch="all"
license="Apache-2.0"
-makedepends="py3-setuptools python3-dev"
+makedepends="py3-gpep517 py3-setuptools py3-wheel python3-dev"
depends="python3"
-subpackages="cython-doc"
-source="cython-$pkgver.tar.gz::https://github.com/cython/cython/archive/$pkgver.tar.gz
-cython-test-fix.patch"
-
-# compatible fix for removing dev subpkg from apkbuild
-# cython is not a library but a compiler and does not need a dev subpackage
-provides=cython-dev
+subpackages="cython-pyc cython-doc"
+source="cython-$pkgver.tar.gz::https://github.com/cython/cython/archive/$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel --wheel-dir .dist --output-fd 3 3>&1 >&2
}
check() {
- python3 runtests.py -j${JOBS:-$(nproc)}
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 runtests.py -j${JOBS:-$(nproc)}
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
install -Dm 644 LICENSE.txt "$pkgdir/usr/share/licenses/cython/license"
install -Dm 644 README.rst "$pkgdir/usr/share/doc/cython/readme.rst"
}
sha512sums="
-387a827f3cb7428248019744e3ed606a133d98ac882b83624d24ae0fdf8a8f2334978555d7d84e5cc4adaf715c541fef64e45bcbdda85ca33473c21f99360be8 cython-0.29.24.tar.gz
-6a924351d54636edf5c65309c285a7298a6b25d28a81812c636fd16901471b4d9522f271ec28c2e03c0a48fa926aa52bfbe60bf4cb80073d7837b81828a7220c cython-test-fix.patch
+97aa831cea96c1f3c51653c51fadb0aea8bdfdb076a2c898862637f52b826bcb9162d1b7aade3304c5650d0b894cb1083052f036365d79cd3d390e0486b33ac5 cython-3.0.10.tar.gz
"