aboutsummaryrefslogtreecommitdiffstats
path: root/main/debootstrap/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/debootstrap/APKBUILD')
-rw-r--r--main/debootstrap/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/main/debootstrap/APKBUILD b/main/debootstrap/APKBUILD
index 9ce17abc689..981c32ddeae 100644
--- a/main/debootstrap/APKBUILD
+++ b/main/debootstrap/APKBUILD
@@ -1,17 +1,17 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=debootstrap
-pkgver=1.0.124
+pkgver=1.0.134
pkgrel=0
pkgdesc="Debian/Ubuntu bootstrap scripts"
url="https://packages.qa.debian.org/d/debootstrap.html"
arch="noarch"
license="MIT"
options="!check" # upstream doesn't have a test suite
-depends="debian-archive-keyring dpkg tar"
+depends="debian-archive-keyring dpkg perl tar"
subpackages="$pkgname-doc"
-source="http://ftp.debian.org/debian/pool/main/d/debootstrap/debootstrap_$pkgver.tar.gz"
-builddir="$srcdir/debootstrap"
+source="https://salsa.debian.org/installer-team/debootstrap/-/archive/$pkgver/debootstrap-$pkgver.tar.bz2
+ auto-detect-arch.patch"
package() {
make DESTDIR="$pkgdir" install
@@ -19,4 +19,7 @@ package() {
"$pkgdir"/usr/share/man/man8/$pkgname.8
}
-sha512sums="bc028f7fec85b35a5f826044d8aff22b6fdf69e7e2c5f5c95e4b92327bcffa6411b5b21869833d10fb1f70316271149470921ad4310d61fdd3c73b65bd8009f1 debootstrap_1.0.124.tar.gz"
+sha512sums="
+e7b9726632d3816975c8cbd0020882f69db6d2a84f6c2d086a4e002c58afa61f8b08a8a35b40dd6a284e2cdb584817292462e5dc354fb83d177d50a56aa8cda6 debootstrap-1.0.134.tar.bz2
+a349d9d8f5fe9e4ccb67d7206d5e87174722c0e0ee07405557662e94fb3c330a922f9cfe12bbd096103cbbe2146262ea300d9e1854f7fef77f4f1949984f5591 auto-detect-arch.patch
+"