aboutsummaryrefslogtreecommitdiffstats
path: root/main/device-mapper/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/device-mapper/APKBUILD')
-rw-r--r--main/device-mapper/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/main/device-mapper/APKBUILD b/main/device-mapper/APKBUILD
new file mode 100644
index 00000000000..33841375672
--- /dev/null
+++ b/main/device-mapper/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=device-mapper
+pkgver=1.02.28
+pkgrel=0
+pkgdesc="Device mapper userspace library and tools."
+url="http://sourceware.org/dm/"
+license="GPL"
+depends="uclibc"
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://sources.redhat.com/pub/dm/$pkgname.$pkgver.tgz"
+
+build() {
+ cd "$srcdir"/$pkgname.$pkgver
+
+ ./configure --prefix=/usr \
+ --sbindir=/sbin \
+ --libdir=/lib \
+ --enable-dmeventd \
+ CLDFLAGS="$LDFLAGS" \
+ || return 1
+
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install
+}
+md5sums="c9ae0776994a419f9e1ba842164bb626 device-mapper.1.02.28.tgz"