aboutsummaryrefslogtreecommitdiffstats
path: root/main/dhcpcd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/dhcpcd/APKBUILD')
-rw-r--r--main/dhcpcd/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/main/dhcpcd/APKBUILD b/main/dhcpcd/APKBUILD
index 75627412622..38d7d6ef8b5 100644
--- a/main/dhcpcd/APKBUILD
+++ b/main/dhcpcd/APKBUILD
@@ -2,23 +2,22 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dhcpcd
-pkgver=8.1.1
+pkgver=10.0.6
pkgrel=0
pkgdesc="RFC2131 compliant DHCP client"
url="https://roy.marples.name/projects/dhcpcd"
arch="all"
license="BSD-2-Clause"
-makedepends="linux-headers bsd-compat-headers dbus-dev"
-install="$pkgname.post-upgrade"
+makedepends="linux-headers bsd-compat-headers"
+install="$pkgname.post-upgrade $pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-openrc"
-source="https://roy.marples.name/downloads/dhcpcd/dhcpcd-$pkgver.tar.xz
+source="https://github.com/NetworkConfiguration/dhcpcd/releases/download/v$pkgver/dhcpcd-$pkgver.tar.xz
busybox-logger.patch
fix-chrony-conf-location.patch
dhcpcd.initd
- musl.patch
"
+
build() {
- CFLAGS="$CFLAGS -D_GNU_SOURCE -DHAVE_PRINTF_M"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -27,8 +26,11 @@ build() {
--localstatedir=/var \
--libexecdir=/usr/lib/$pkgname \
--dbdir=/var/lib/$pkgname \
- --rundir=/run \
+ --rundir=/run/dhcpcd \
+ --runstatedir=/run/dhcpcd \
--enable-ipv6 \
+ --enable-privsep \
+ --enable-seccomp \
--without-dev \
--without-udev
make
@@ -44,8 +46,9 @@ package() {
"$pkgdir"/etc/init.d/dhcpcd
}
-sha512sums="2acca049029fa629ab6ba4f45959a2b67cf20c13e8659e71c1d5688fff5527df7007a4edfd9e88634ded9c76179d91b3e7adb92719f7a049d4f0cdbbd06e9a79 dhcpcd-8.1.1.tar.xz
-692b2c8c75166fabd512a7cc69c650f9391e0f682ce9cbe1771bfa44e82dcf09e322c46493c45ca75000f479d3cddde306754ba31d28a798a15e2b79a56045f0 busybox-logger.patch
+sha512sums="
+403d612080c6f1397003dc6a16f59bb5d1d3d3479e3656c598acde4c4aafe1cfa374725c5ae3dddb4972c0f23ffd55d04c3703b97bed5b7060855b61b7738004 dhcpcd-10.0.6.tar.xz
+b6bdaac9fc0d5d2d7e8c5e30d1a45db1cff2284d01f92f8821b2f03aaff4e0dbd8cbfbced96d8d9d934dc11f22b792a8345d634d8e4e3b84f43016b7e866e302 busybox-logger.patch
1c19eed0f7a008ee96ea392beb327169ff8c83fc27fed20f65f05c9125f60629ebe3474c5e6a7cf4aeeea448fde4264c9b84916efacd67d47ab908c47b1fc3a5 fix-chrony-conf-location.patch
-d4610be2b694ae3c7ba2defc4273635b87579c51ae5a74cc4c3ecce66dfc7cb32c4713655ac0324781445c5271fcfdc14b20584b332a2c1e2dbbeaf7ff17b44b dhcpcd.initd
-082aa80798476917e2a86003cb95136212cbb9b8da986e7d8186d7f3d857e81a4cb03af56296484e035e5006d36c695ef57f571ea9c1fd18b4200a9cf745a6b4 musl.patch"
+7fb44b82a6fa25ee6249fc4835853a4c1fc7d327653efabd9fde303b1f306b3aa6956b2621b55a24fc007ec7ad878ce50e7418ebff0b17fece76e2fdd9e5190d dhcpcd.initd
+"