aboutsummaryrefslogtreecommitdiffstats
path: root/main/ethtool
diff options
context:
space:
mode:
Diffstat (limited to 'main/ethtool')
-rw-r--r--main/ethtool/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/main/ethtool/APKBUILD b/main/ethtool/APKBUILD
index fc23e4a0ca9..02b2500194b 100644
--- a/main/ethtool/APKBUILD
+++ b/main/ethtool/APKBUILD
@@ -1,22 +1,28 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ethtool
-pkgver=6
-pkgrel=2
+pkgver=3.2
+pkgrel=0
pkgdesc="gkernel ethtool"
url="http://sourceforge.net/projects/gkernel/"
arch="all"
license="GPL"
depends=""
makedepends=""
-source="http://easynews.dl.sf.net/sourceforge/gkernel/$pkgname-$pkgver.tar.gz"
+source="http://www.kernel.org/pub/software/network/ethtool/ethtool-$pkgver.tar.xz"
subpackages="$pkgname-doc"
-build ()
-{
- cd "$srcdir/$pkgname-$pkgver"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--mandir=/usr/share/man
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
}
-md5sums="3b721ec27f17ebf320ba8c505cf66d9c ethtool-6.tar.gz"
+
+md5sums="4ed4a9dfd2039aa416176a9c06497b00 ethtool-3.2.tar.xz"