summaryrefslogtreecommitdiffstats
path: root/main/faenza-icon-theme
diff options
context:
space:
mode:
Diffstat (limited to 'main/faenza-icon-theme')
-rw-r--r--main/faenza-icon-theme/APKBUILD202
1 files changed, 200 insertions, 2 deletions
diff --git a/main/faenza-icon-theme/APKBUILD b/main/faenza-icon-theme/APKBUILD
index f5e0740c6d6..23d0a36c9af 100644
--- a/main/faenza-icon-theme/APKBUILD
+++ b/main/faenza-icon-theme/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=faenza-icon-theme
pkgver=1.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="icons designed to go in tandem with equinox themes"
arch="noarch"
url="http://tiheum.deviantart.com/art/Faenza-Icons-173323228"
@@ -10,7 +10,48 @@ license="GPL"
depends=
makedepends=
install=
-subpackages=
+subpackages="$pkgname-extras
+
+ $pkgname-abiword
+ $pkgname-audacious
+ $pkgname-audacity
+ $pkgname-evince
+ $pkgname-firefox
+ $pkgname-geany
+ $pkgname-gimp
+ $pkgname-glade
+ $pkgname-gnome-panel:gnome_panel
+ $pkgname-gnome-session:gnome_session
+ $pkgname-gnumeric
+ $pkgname-gparted
+ $pkgname-imagemagick
+ $pkgname-inkscape
+ $pkgname-midori
+ $pkgname-mplayer
+ $pkgname-pidgin
+ $pkgname-shotwell
+ $pkgname-thunar
+ $pkgname-transmission
+ $pkgname-truecrypt
+ $pkgname-vim
+ $pkgname-vlc
+ $pkgname-wine
+ $pkgname-wireshark
+ $pkgname-xbmc
+ $pkgname-xchat
+ $pkgname-xfce4-appfinder:xfce4_appfinder
+ $pkgname-xfce4-panel:xfce4_panel
+
+ $pkgname-deadbeef
+ $pkgname-dia
+ $pkgname-emacs
+ $pkgname-evolution
+ $pkgname-hardinfo
+ $pkgname-thunderbird
+ $pkgname-totem
+ "
+
+
source="https://launchpad.net/~tiheum/+archive/equinox/+files/faenza-icon-theme_$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-1.3
@@ -22,4 +63,161 @@ package() {
cp -dpRf Faenza* "$pkgdir"/usr/share/icons
}
+_app() {
+ local app="$1" glob=
+ shift
+ pkgdesc="$pkgname - $app"
+ replaces="$pkgname"
+ if [ -n "$app" ]; then
+ install_if="$pkgname=$pkgver-r$pkgrel $1"
+ else
+ install_if=
+ fi
+ cd "$pkgdir"
+ for glob in "$@"; do
+ find . -name "$glob" | while read path; do
+ mkdir -p "$subpkgdir/${path%/*}"
+ mv "$pkgdir/$path" "$subpkgdir/$path" || return 1
+ done
+ done
+}
+
+abiword() { _app abiword 'abiword*'; }
+audacious() { _app audacious 'audacious*'; }
+audacity() { _app audacity 'audacity*'; }
+evince() { _app evince 'evince*'; }
+firefox() { _app firefox '*firefox*'; }
+geany() { _app geany 'geany*'; }
+gimp() { _app gimp 'gimp*'; }
+glade() { _app glade 'glade*'; }
+gnome_panel() { _app gnome-panel 'gnome-panel*'; }
+gnome_session() { _app gnome-session 'gnome-session*'; }
+gnumeric() { _app gnumeric 'gnumeric*'; }
+gparted() { _app gparted 'gparted*'; }
+imagemagick() { _app imagemagick 'imagemagick*'; }
+inkscape() { _app inkscape 'inkscape*'; }
+midori() { _app midori 'midori*'; }
+mplayer() { _app mplayer 'mplayer*'; }
+pidgin() { _app pidgin 'pidgin*'; }
+shotwell() { _app shotwell 'shotwell*'; }
+thunar() { _app thunar 'thunar*'; }
+transmission() { _app transmission 'transmission*'; }
+truecrypt() { _app truecrypt 'truecrypt*'; }
+vim() { _app vim 'vim*'; }
+vlc() { _app vlc 'vlc*'; }
+wine() { _app wine '*wine*'; }
+wireshark() { _app wireshark 'wireshark*'; }
+xbmc() { _app xbmc 'xbmc*'; }
+xchat() { _app xchat 'xchat*'; }
+xfce4_appfinder() { _app xfce4-appfinder 'xfce4-appfinder*'; }
+xfce4_panel() { _app xfce4-panel 'xfce4-panel*'; }
+
+# testing
+deadbeef() { _app deadbeef 'deadbeef*'; }
+dia() { _app dia 'dia*'; }
+emacs() { _app emacs 'emacs*'; }
+evolution() { _app evolution '*evolution*'; }
+hardinfo() { _app hardinfo 'hardinfo*'; }
+thunderbird() { _app thunderbird '*thunderbird*'; }
+totem() { _app totem 'totem*'; }
+
+
+#unsupported apps
+extras() { _app "" \
+ '*adobe*' \
+ '*chess*' \
+ '*crom*' \
+ '*ubuntu*' \
+ 'WorldOfGoo*' \
+ 'amue*' \
+ 'blender*' \
+ 'bluefish*' \
+ 'bluegriffon' \
+ 'brasero*' \
+ 'bug-buddy*' \
+ 'chromium-browser' \
+ 'clementine*' \
+ 'comix' \
+ 'computerjanitor*' \
+ 'desura*' \
+ 'docky*' \
+ 'dropbox*' \
+ 'eclipse*' \
+ 'emesene' \
+ 'emsene*' \
+ 'eog.*' \
+ 'exaile*' \
+ 'f-spot*' \
+ 'fedora*' \
+ 'filezilla' \
+ 'frostwire*' \
+ 'gajim*' \
+ 'gbrainy*' \
+ 'gcstar*' \
+ 'glippy*' \
+ 'gnome-activity' \
+ 'gnome-aisleriot' \
+ 'gnome-do*' \
+ 'gnome-freecell' \
+ 'gnome-glines' \
+ 'gnome-gnect*' \
+ 'gnome-gnibbles' \
+ 'gnome-iagno' \
+ 'gnome-klotski' \
+ 'gnome-lightsoff' \
+ 'gnome-mahjong*' \
+ 'gnome-mines*' \
+ 'gnome-mines*' \
+ 'gnome-quadrapassel' \
+ 'gnome-robots' \
+ 'gnome-samegnome' \
+ 'gnome-sudoku' \
+ 'gnome-swell-foop' \
+ 'gnome-tali*' \
+ 'gnome-tetravex' \
+ 'google-chrome' \
+ 'googleearth*' \
+ 'guayadeque*' \
+ 'gwibber*' \
+ 'haguichi*' \
+ 'homebank*' \
+ 'icedove' \
+ 'iceweasel' \
+ 'jdownloader' \
+ 'jockey*' \
+ 'library-internet-radio' \
+ 'libreoffice*' \
+ 'logviewer' \
+ 'miro*' \
+ 'mono*' \
+ 'mypaint*' \
+ 'netbeans*' \
+ 'nvidia-settings*' \
+ 'ooo-*' \
+ 'ooo-*' \
+ 'openttd*' \
+ 'opera*' \
+ 'picasa*' \
+ 'pino*' \
+ 'pithos*' \
+ 'pitivi*' \
+ 'ppa.*' \
+ 'rhythmbox' \
+ 'rythmbox*' \
+ 'shutter*' \
+ 'skype*' \
+ 'softwarecenter-debian' \
+ 'spotify*' \
+ 'steam*' \
+ 'stellarium*' \
+ 'synapse*' \
+ 'telepathy*' \
+ 'tomboy*' \
+ 'tvtime*' \
+ 'wxbanker*' \
+ 'xine' \
+ 'xournal*' \
+
+}
+
md5sums="b5339b70cbb821b583499e725957b150 faenza-icon-theme_1.3.1.tar.gz"