summaryrefslogtreecommitdiffstats
path: root/main/fakeroot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/fakeroot/APKBUILD')
-rw-r--r--main/fakeroot/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/fakeroot/APKBUILD b/main/fakeroot/APKBUILD
new file mode 100644
index 00000000000..d9bfb67b871
--- /dev/null
+++ b/main/fakeroot/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=fakeroot
+pkgver=1.12.4
+pkgrel=0
+pkgdesc="Gives a fake root environment, useful for building packages as a non-privileged user"
+license='GPL'
+url="http://packages.debian.org/fakeroot"
+depends=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.tar.gz
+ busybox-compat.patch"
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -p1 < ../busybox-compat.patch
+ CONFIG_SHELL=/bin/sh ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="aaefede2405a40c87438e7e833d69b70 fakeroot_1.12.4.tar.gz
+ea7b7e3065090d72804cdf4719dd5832 busybox-compat.patch"