aboutsummaryrefslogtreecommitdiffstats
path: root/main/fetchmail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/fetchmail/APKBUILD')
-rw-r--r--main/fetchmail/APKBUILD68
1 files changed, 0 insertions, 68 deletions
diff --git a/main/fetchmail/APKBUILD b/main/fetchmail/APKBUILD
deleted file mode 100644
index 356aec56b01..00000000000
--- a/main/fetchmail/APKBUILD
+++ /dev/null
@@ -1,68 +0,0 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=fetchmail
-pkgver=6.4.6
-pkgrel=0
-pkgdesc="A remote-mail retrieval and forwarding utility"
-url="https://www.fetchmail.info/"
-arch="all"
-license="GPL-2.0-or-later AND Public Domain"
-pkgusers="fetchmail"
-pkggroups="fetchmail"
-makedepends="openssl-dev python3"
-install="fetchmail.pre-install"
-subpackages="
- $pkgname-doc
- $pkgname-openrc
- fetchmailconf::noarch
- "
-source="https://downloads.sourceforge.net/fetchmail/fetchmail-$pkgver.tar.xz
- $pkgname.initd
- $pkgname.confd
- "
-
-build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --with-ssl \
- --disable-nls \
- --enable-POP3 \
- --enable-IMAP \
- --without-hesiod \
- --enable-ETRN \
- --enable-NTLM \
- --enable-SDPS \
- --enable-RPA \
- --without-kerberos5 \
- --without-gssapi \
- --enable-fallback=no
- make
-}
-
-package() {
- make DESTDIR="$pkgdir" install
- install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
- install -o fetchmail -g fetchmail -d "$pkgdir"/var/lib/fetchmail \
- "$pkgdir"/var/run/fetchmail
-}
-
-fetchmailconf() {
- depends="python3 py3-future python3-tkinter"
- pkgdesc="GUI for generating fetchmail configuration files"
- install=""
-
- amove usr/bin/fetchmailconf*
- amove usr/lib/python3*/site-packages/fetchmailconf.py*
- amove usr/lib/python3*/site-packages/__pycache__/fetchmailconf*
-}
-
-
-sha512sums="0101c79039c754b55e94181fb6c51f07782e581123e25ac72a99c2abe8f3ac4af3e97b12bab50813fb9300179b921c80d0bc60f528ad73c914ad266e29fb6513 fetchmail-6.4.6.tar.xz
-9520ec6616f4004d091b1c908d3ea38e104ad8f6595959a3cd3ef7544d05e3b75854631289e167ead08479250d04584d3f1855668a7a0ebd16a1ee9106f3b0b3 fetchmail.initd
-6f031ec6bd4a3ae53cd04fbd8470f4d10bd46ca29cabffa634a6801aa2e7707169855fbc045ced3c9a69523e694511a3f076b611678143e49339c8ccac98074e fetchmail.confd"