aboutsummaryrefslogtreecommitdiffstats
path: root/main/fish/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/fish/APKBUILD')
-rw-r--r--main/fish/APKBUILD54
1 files changed, 33 insertions, 21 deletions
diff --git a/main/fish/APKBUILD b/main/fish/APKBUILD
index c0487286f14..a18c2917c2e 100644
--- a/main/fish/APKBUILD
+++ b/main/fish/APKBUILD
@@ -1,36 +1,57 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer:
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=fish
-pkgver=3.3.1
+pkgver=3.7.1
pkgrel=0
pkgdesc="Modern interactive commandline shell"
url="https://fishshell.com/"
arch="all"
license="GPL-2.0-only"
depends="bc"
-depends_doc="util-linux" # Requires 'ul' program
+depends_doc="util-linux-misc" # Requires 'ul' program
depends_dev="$pkgname-tools"
-makedepends="cmake doxygen ncurses-dev ncurses pcre2-dev py3-sphinx"
+makedepends="cmake doxygen gettext-dev ncurses-dev ncurses pcre2-dev py3-sphinx samurai"
checkdepends="py3-pexpect bash"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-tools::noarch"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools::noarch $pkgname-lang"
source="https://github.com/fish-shell/fish-shell/releases/download/$pkgver/fish-$pkgver.tar.xz
README.alpine
"
-# temp allow textrels on riscv64
-[ "$CARCH" = "riscv64" ] && options="$options textrels"
+# these were moved to the correct place, but on upgrade, fish would upgrade first,
+# which would conflict right before the others move, so we need a replaces= for
+# one transaction.
+replaces="
+ black-fish-completion
+ curl-fish-completion
+ docker-fish-completion
+ flatpak-fish-completion
+ helm-fish-completion
+ hugo-fish-completion
+ kind-fish-completion
+ mdbook-fish-completion
+ minikube-fish-completion
+ ouch-fish-completion
+ rclone-fish-completion
+ rustup-fish-completion
+ starship-fish-completion
+ topgrade-fish-completion
+ "
+
+# secfixes:
+# 3.4.0-r0:
+# - CVE-2022-20001
build() {
- cmake -B build \
+ CXXFLAGS="$CXXFLAGS -flto=auto" \
+ cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_SYSCONFDIR=/etc \
-DBUILD_DOCS=TRUE
- cmake --build build
- cmake --build build --target fish_tests
+ cmake --build build --target all fish_tests
}
check() {
@@ -47,15 +68,6 @@ package() {
mkdir -p "$pkgdir"/usr/lib
mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib
-
- # https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/10159#note_101679
- rm "$pkgdir"/usr/share/fish/completions/rustup.fish
-
- # https://github.com/fish-shell/fish-shell/issues/2436
- rm "$pkgdir"/usr/share/fish/completions/docker.fish
-
- # provided by minikube-fish-completion
- rm "$pkgdir"/usr/share/fish/completions/minikube.fish
}
doc() {
@@ -72,6 +84,6 @@ tools() {
}
sha512sums="
-fc50ca44fab3f2d942284d4f714150f7ccf1e49c73da36f8d4ae4a33a9b3280f98bed15848839f5d443b4274fd0ff90174bafa6a8e9a4da226dda63d7766a660 fish-3.3.1.tar.xz
+f1605c400c5d5494f37b92dd386963dba7a3f3c401c369aaf3ff616d9d94836a0138d26074be24c92d94d9d7b625513800899c9431f5e21be0757eb0a0bfd3fe fish-3.7.1.tar.xz
c28cef48e3d9cde4956d36192dc221e63eca89282a937e2683578ac0958d98a9c54420aea4f1d91d516f5ee2c74589a75865a973305421e1ad0a9e70854dff4f README.alpine
"