aboutsummaryrefslogtreecommitdiffstats
path: root/main/fish/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/fish/APKBUILD')
-rw-r--r--main/fish/APKBUILD65
1 files changed, 26 insertions, 39 deletions
diff --git a/main/fish/APKBUILD b/main/fish/APKBUILD
index 27e33402dbd..a18c2917c2e 100644
--- a/main/fish/APKBUILD
+++ b/main/fish/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=fish
-pkgver=3.5.1
-pkgrel=1
+pkgver=3.7.1
+pkgrel=0
pkgdesc="Modern interactive commandline shell"
url="https://fishshell.com/"
arch="all"
@@ -18,23 +18,40 @@ source="https://github.com/fish-shell/fish-shell/releases/download/$pkgver/fish-
README.alpine
"
+# these were moved to the correct place, but on upgrade, fish would upgrade first,
+# which would conflict right before the others move, so we need a replaces= for
+# one transaction.
+replaces="
+ black-fish-completion
+ curl-fish-completion
+ docker-fish-completion
+ flatpak-fish-completion
+ helm-fish-completion
+ hugo-fish-completion
+ kind-fish-completion
+ mdbook-fish-completion
+ minikube-fish-completion
+ ouch-fish-completion
+ rclone-fish-completion
+ rustup-fish-completion
+ starship-fish-completion
+ topgrade-fish-completion
+ "
+
# secfixes:
# 3.4.0-r0:
# - CVE-2022-20001
-# temp allow textrels on riscv64
-[ "$CARCH" = "riscv64" ] && options="$options textrels"
-
build() {
+ CXXFLAGS="$CXXFLAGS -flto=auto" \
cmake -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=MinSizeRel \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_SYSCONFDIR=/etc \
-DBUILD_DOCS=TRUE
- cmake --build build
- cmake --build build --target fish_tests
+ cmake --build build --target all fish_tests
}
check() {
@@ -51,36 +68,6 @@ package() {
mkdir -p "$pkgdir"/usr/lib
mv "$pkgdir"/usr/share/pkgconfig "$pkgdir"/usr/lib
-
- # https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/10159#note_101679
- rm "$pkgdir"/usr/share/fish/completions/rustup.fish
-
- # https://github.com/fish-shell/fish-shell/issues/2436
- rm "$pkgdir"/usr/share/fish/completions/docker.fish
-
- # provided by minikube-fish-completion
- rm "$pkgdir"/usr/share/fish/completions/minikube.fish
-
- # provided by flatpak-fish-completion
- rm "$pkgdir"/usr/share/fish/completions/flatpak.fish
-
- # provided by helm-fish-completion
- rm "$pkgdir"/usr/share/fish/completions/helm.fish
-
- # provided by curl-fish-completion
- rm "$pkgdir"/usr/share/fish/completions/curl.fish
-
- # provided by hugo-fish-completion
- rm "$pkgdir"/usr/share/fish/completions/hugo.fish
-
- # provided by starship-fish-completion
- rm "$pkgdir"/usr/share/fish/completions/starship.fish
-
- # provided by rclone-fish-completion
- rm "$pkgdir"/usr/share/fish/completions/rclone.fish
-
- # provided by mdbook-fish-completion
- rm "$pkgdir"/usr/share/fish/completions/mdbook.fish
}
doc() {
@@ -97,6 +84,6 @@ tools() {
}
sha512sums="
-328e3d972f9e7cffe161515540f00a97c5cbe11b43ec293090bedb96a6a8e689e07ceafecb3efcd0e378edea59811adb0acc011d5885ac28d98838387c678235 fish-3.5.1.tar.xz
+f1605c400c5d5494f37b92dd386963dba7a3f3c401c369aaf3ff616d9d94836a0138d26074be24c92d94d9d7b625513800899c9431f5e21be0757eb0a0bfd3fe fish-3.7.1.tar.xz
c28cef48e3d9cde4956d36192dc221e63eca89282a937e2683578ac0958d98a9c54420aea4f1d91d516f5ee2c74589a75865a973305421e1ad0a9e70854dff4f README.alpine
"