summaryrefslogtreecommitdiffstats
path: root/main/font-bh-type1
diff options
context:
space:
mode:
Diffstat (limited to 'main/font-bh-type1')
-rw-r--r--main/font-bh-type1/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/font-bh-type1/APKBUILD b/main/font-bh-type1/APKBUILD
new file mode 100644
index 00000000000..43b55663315
--- /dev/null
+++ b/main/font-bh-type1/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=font-bh-type1
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="X.org bh Type1 fonts"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends="encodings font-alias mkfontscale mkfontdir fontconfig"
+makedepends="pkgconfig font-util-dev bdftopcf"
+install=
+source="http://xorg.freedesktop.org/releases/individual/font/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --with-mapfiles=/usr/share/fonts/util \
+ --with-fontdir=/usr/share/fonts/Type1
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" MKFONTDIR=: MKFONTSCALE=: install || return 1
+}
+
+md5sums="46588b22678e440741d6220bc3945cbf font-bh-type1-1.0.0.tar.bz2"